tonyakuznetsova
?>

Как решить эту на pascal напишите программу, которая по изображению поля для игры в «крестики-нолики» определит, могла ли такая ситуация возникнуть в результате игры с соблюдением всех правил. напомним, что игра в «крестики-нолики» ведется на поле 3x3. два игрока ходят по очереди. первый ставит крестик, а второй – нолик. ставить крестик и нолик разрешается в любую еще не занятую клетку поля. когда один из игроков поставит три своих знака в одной горизонтали, вертикали или диагонали, или когда все клетки поля окажутся заняты, игра заканчивается. входные данные вводится три строки по три числа в каждой, описывающих игровое поле. число 0 обозначает пустую клетку, 1 – крестик, 2 – нолик. числа в строке разделяются пробелами. выходные данные требуется вывести слово yes, если указанная ситуация могла возникнуть в ходе игры, и no в противном случае. примеры входные данные 1 1 1 1 1 1 1 1 1 выходные данные no входные данные 2 1 1 1 1 2 2 2 1 выходные данные yes входные данные 1 1 1 2 0 2 0 0 0 выходные данные yes входные данные 0 0 0 0 1 0 0 0 0 выходные данные yes входные данные 1 1 1 2 2 2 0 0 0 выходные данные no

Информатика

Ответы

mos-5nica
Var
 a:array[1..3,1..3] of integer;
 t:array[0..2] of boolean;
 k:array[0..2] of integer;
 i,j:integer;
 res:boolean;

begin
 for i := 1 to 3 do
 for j := 1 to 3 do
   read(a[i,j]);
 for i := 0 to 2 do
  begin
  k[i] := 0;
  t[i] := false;
  end;
 
 for i := 1 to 3 do
 for j := 1 to 3 do
   k[a[i,j]] := k[a[i,j]] + 1;
 
 for i := 1 to 3 do
   begin
   if (a[i,1] = a[i,2]) and (a[i,2] = a[i,3]) then
     t[a[i,1]] := true;
   if (a[1,i] = a[2,i]) and (a[2,i] = a[3,i]) then
     t[a[1,i]] := true;
   end;
 if (a[1,1] = a[2,2]) and (a[2,2] = a[3,3]) then
   t[a[2,2]] := true;
 if (a[3,1] = a[2,2]) and (a[2,2] = a[1,3]) then
   t[a[2,2]] := true;
 
 res := true;
 
 if (k[1] - k[2] > 1) or (k[1] - k[2] < 0) then
   res := false;
 
 if t[1] and ( t[2] or (k[1] = k[2]) ) then
   res := false;
 
 if res then
   writeln('YES')
 else
   writeln('NO')
end.
kuk-nina
1)   F=¬A+B*C+B

A B C  ¬A  B*C   F
0 0 0     1    0       1
0 0 1      1   0       1
0 1 0      1     0      1
0 1 1      1     1      1
1 0 0      0     0      0
1 0 1     0     0      0
1 1 0     0     0       1
1 1 1     0     1       1

2)   F = A+B*C
A B C    B*C     F
0 0 0      0        0
0 0 1      0        0
0 1 0      0        0
0 1 1      1        1
1 0 0      0         1
1 0 1      0         1
1 1 0      0         1
1 1 1      1          1

3)  F = A*¬B*C
A B C   ¬B   F
0  0 0     1    0
0 0 1      1     0
0 1 0       0    0
0 1 1       0     0
1 0 0        1    0
1 0 1        1    1
1 1 0        0     0
1 1 1       0       0
dmdlir
Условие:
Информационный вес сообщения 4 КБ.Сообщение составлено из кириллицы без различия строчных и заглавных букв.Сколько символов в сообщении?

Решение:
ну вообще вес символа зависит от кодировки и обычно это 1 байт или 2 байта для юникода, тогда ответ 4*1024 = 4096 символов или 4*1024/2 = 2048 для юникода

если же подразумевается отдельный алфавит, то тогда считаем мощность - 33 символа кажется в кириллице
ближайшая степень двойки = 64 = 2^6 т.е. 6 бит на символ
4*1024*8 {бит} / 6 {бит/символ} =5461,33333 символов = 5461 символ

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Как решить эту на pascal напишите программу, которая по изображению поля для игры в «крестики-нолики» определит, могла ли такая ситуация возникнуть в результате игры с соблюдением всех правил. напомним, что игра в «крестики-нолики» ведется на поле 3x3. два игрока ходят по очереди. первый ставит крестик, а второй – нолик. ставить крестик и нолик разрешается в любую еще не занятую клетку поля. когда один из игроков поставит три своих знака в одной горизонтали, вертикали или диагонали, или когда все клетки поля окажутся заняты, игра заканчивается. входные данные вводится три строки по три числа в каждой, описывающих игровое поле. число 0 обозначает пустую клетку, 1 – крестик, 2 – нолик. числа в строке разделяются пробелами. выходные данные требуется вывести слово yes, если указанная ситуация могла возникнуть в ходе игры, и no в противном случае. примеры входные данные 1 1 1 1 1 1 1 1 1 выходные данные no входные данные 2 1 1 1 1 2 2 2 1 выходные данные yes входные данные 1 1 1 2 0 2 0 0 0 выходные данные yes входные данные 0 0 0 0 1 0 0 0 0 выходные данные yes входные данные 1 1 1 2 2 2 0 0 0 выходные данные no
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Koranna1986
Наталья Юрьевич1228
usmanovayanq2626
imosal
Tarapovskaya
brendacepedam
anchutk3016
мурувватовна викторович569
Belov
okabankova7
Zimin1111
Д.О. Игорь
Chuhnin195107364
uttgroup
denis302007