nasrelza1012
?>

Написать программу на языке pascal палиндромом называется строка, которая одинаково читается как слева направо, так и справа налево. рассмотрим все натуральные числа, запись которых в десятичной системе счисления является палиндромом (при этом запись не начинается с нуля например, числа 121 и 1331 являются палиндромами, а число 123 — нет. по данному числу n найдите n-e в порядке возрастания число-палиндром. программа получает на вход одно натуральное число n, не превосходящее 100 000. программа должна вывести одно натуральное число — n-е в порядке возрастания число-палиндром. пример входных и выходных данных ввод 20 вывод 111

Информатика

Ответы

didizain
Var
  s: string;
  n,m: integer;

 begin
  readln(n);
  if (n <= 9) then write(n)
  else if (n <= 9 + 9) then
     begin
       s := inttostr(n - 9);
      write(s + s);
     end
  else if (n <= 9 + 9 + 90) then
     begin
       s := inttostr(n - 9 -9 + 10 -1);
       m:=s.Length-1;
       write(s + s[m:0:-1]);
     end
  else if (n <= 9 + 9 + 90 + 90) then
     begin
       s := inttostr(n - 9 - 9 + 90 + 10 - 1);
       write(s + s[::-1]);
     end
  else if (n <= 9 + 9 + 90 + 90 + 900) then
     begin
       s := inttostr(n - 9 - 9 - 90 - 90 + 100 - 1);
       m:=s.Length-1;
write(s + s[m:0:-1]);
     end
  else if (n <= 9 + 9 + 90 + 90 + 900 + 900) then
     begin
       s := inttostr(n - 9 - 9 - 90 - 90 - 900 + 100 - 1);
       write(s + s[::-1]);
     end
  else if (n <= 9 + 9 + 90 + 90 + 900 + 900 + 9000) then
     begin
       s := inttostr(n - 9 - 9 - 90 - 90 - 900 - 900 + 1000 - 1);
       m:=s.Length-1;
       write(s + s[m:0:-1]);
     end
  else if (n <= 9 + 9 + 90 + 90 + 900 + 900 + 9000 + 9000) then
     begin
       s := inttostr(n - 9 - 9 - 90 - 90 - 900 - 900 - 9000 + 1000 - 1 );
       write(s + s[::-1]);
     end
  else
     begin
       s := inttostr(n - 9 - 9 - 90 - 90 - 900 - 900 - 9000 - 9000 + 10000 - 1);
       m:=s.Length-1;
       write(s + s[m:0:-1]);
     end
end.
Ivanova.i.bkrasheninnikov

Программа:

Pascal:

var

 A: array of integer = (-10, 16, 3, -19, 0, -10, 30);

 i, pr: integer;

begin

 writeln('Массив: ', A);

 write('Отрицательные элементы: ');

 for i := 0 to 6 do begin

   if A[i] < 0 then

     write(A[i], ' ');

   if (A[i] > 0) and (A[i] mod 2 = 0) then

     pr *= A[i];

 end;

 

 writeln(#13, 'Произведение положительных элементов, кратных 2: ', pr);

end.

В начале выделяем память массиву и сразу заполняем его числами. После - регистрируем переменные, которые будем использовать в дальнейшем. Выводим массив, после - выводим просто надпись "отрицательные элементы". После этого циклом проходимся по элементам массива (в ЯП Pascal 1-й элемент массива имеет порядковый номер 0, поэтому цикл от 0 до 6). Если число отрицательное, вывести его; также в этом цикле находим произведение положительных элементов, кратных двум. В конце выводим произведение положительных элементов.


1. Дан массив A: -10, 16,3,-19,0,-10,30. Вывести отрицательные элементы. 2. Найти произведение полож
Анна498

1 Тема) Когда появились первые боевые роботы?

В 1910 году, вдохновлённый успехами братьев Райт, молодой американский военный инженер из Огайо Чарльз Кеттеринг предложил использовать летательные аппараты без человека. По его замыслу управляемое часовым механизмом устройство в заданном месте должно было сбрасывать крылья и падать как бомба на врага. Получив финансирование армии США, он построил, и с переменным успехом испытал несколько устройств, получивших названия The Kattering Aerial Torpedo, Kettering Bug (или просто Bug), но в боевых действиях они так и не применялись.

Объяснение:

Как то так

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке pascal палиндромом называется строка, которая одинаково читается как слева направо, так и справа налево. рассмотрим все натуральные числа, запись которых в десятичной системе счисления является палиндромом (при этом запись не начинается с нуля например, числа 121 и 1331 являются палиндромами, а число 123 — нет. по данному числу n найдите n-e в порядке возрастания число-палиндром. программа получает на вход одно натуральное число n, не превосходящее 100 000. программа должна вывести одно натуральное число — n-е в порядке возрастания число-палиндром. пример входных и выходных данных ввод 20 вывод 111
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

upmoskovskiy
katushak29
n-896458
zalev
dddddd68
Vitalevna
ирина Альбертовна
Ofelya1308
ulyana-d
Алексей424
bei07
shtankosoyuz1629
md-masya
cashuta
ovdei71