kuk-nina
?>

Решите имеется функция : z=5, 23x^2+4.36x+1.2y^3+0.89y / 2sin(x+y)e^xy . составьте программу нахождения значения функции для значения x и y , вводимые с клавиатуры .

Информатика

Ответы

anaissite6
П1 <-> П0 5 , 2 3 ИП0 x^2 * 4 , 3 6 ИП0 * + 1 , 2 ИП1 3 <-> x^y * + 0 , 8 9 ИП1 * ИП0 ИП1 + sin 2 * ИП0 ИП1 * e^x * / + С/П
yahottabych201379
Чтобы прекратить ввод чисел в массив нужно ввести число "-1".
class ArrayMiddle{
 public static void main(String args[]){
  java.util.Scanner in = new java.util.Scanner(System.in); long eArray[] = new long[1];
  while((eArray[eArray.length-1] = in.nextLong())!=-1){
   long nArray[] = new long[eArray.length+1];
   for(int nCell = 0; nCell<eArray.length; nCell++)nArray[nCell]=eArray[nCell];
   eArray = nArray;
  } eArray[eArray.length-1] = 0;
  for(int cCell = 0; cCell<eArray.length-1; cCell++)eArray[eArray.length-1]+=eArray[cCell];
  System.out.print(eArray[eArray.length-1]/(double)(eArray.length-1));
 }
}
vadim330
Собственно, решение однострочное...

// PascalABC.NET 3.0, сборка 1150 от 22.01.2016
begin
  Writeln('Ср.арифм=',ArrRandom(30,0,1000).Println(', ').
      Where(x->Odd(x)).Average)
end.

Тестовое решение:
611, 443, 634, 637, 44, 297, 286, 431, 130, 767, 388, 513, 827, 681, 619, 810, 586, 697, 206, 823, 294, 238, 354, 138, 411, 141, 873, 864, 715, 564
Ср.арифм=592.875

И пояснение, как это работает, т.е. по сути алгоритм на русском языке.
ArrRandom(30,0,1000) создает массив из 30 элементов и заполняет его случайными значениями из диапазона [0,1000]. Далее этот массив обрабатывается методом Println, который направляет значения элементов на вывод, разделяя их запятой с последующим пробелом и в конце вывода добавляет смену строки. Затем элементы массива проходят фильтр Where(x->Odd(x)), который пропускает через себя только те значения, которые удовлетворяют условию Odd(значение элемента)=True, а мы знаем, что Odd() возвращает True для нечетного аргумента. Далее фильтр элементы обрабатываются методом Average, который умеет принимать набор значений и возвращать их среднее. И наконец, процедура Writeln выводит полученное значение, предваряя его текстовым пояснением.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решите имеется функция : z=5, 23x^2+4.36x+1.2y^3+0.89y / 2sin(x+y)e^xy . составьте программу нахождения значения функции для значения x и y , вводимые с клавиатуры .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Maksim Lokhov
Lazar
shugayzhanna6
cat2572066
Кириллов57
orbbsvsupply
Михайлович1309
Vladimir1172
Olga-Borisovna
serebrennikova99
maglevanyycpt
Avshirokova51
yfetyukov2
Paradismebel
sokolowskayaa