Tselyaritskaya Yurevich
?>

Ручка стоила k рублей. первого сентября стоимость ручки увеличилась ровно на p процентов. определите, сколько ручек можно купить на s рублей после подорожания. программа получает на вход три целых положительных числа. первое число k – стоимость ручки в рублях до подорожания. второе число p – величина подорожания ручки в процентах. третье число s – имеющаяся сумма денег. числа k и s не превосходят 107 , число p не превосходит 100. ручка стоила 33 рубля. после подорожания на 5 % ручка будет стоить 34 рубля 65 копеек (заметим, что, поскольку первоначальная цена ручки была целым числом рублей, после подорожания стоимость ручки будет выражаться целым числом рублей и копеек на 100 рублей после подорожания можно купить 2 ручки. решите на python

Информатика

Ответы

vikola2008
K=float(input())
p=float(input())
s=float(input())
k=k*(1+p/100)
print(int(s/k)
Нана_Елена
Var
  i,n,s:byte; //Здесь мы описываем переменные i- флаг, n - наше число N, s- переменная "деления"
label l1; // Здесь мы 
begin
     l1:i:=0; //Установка метки на начало программы и установка флага на первоначальное значение - НЕТ
     repeat //проверка N на подлинность
     if i=1 then
     write('Не верный ввод данных!Повторите ввод:') 
     else
     write('Введите номер N:'); // Условие при котором в первый раз выводится предложение где нас просят ввести N, а если же мы её ввели не правильно выводится ошибка и опять нас просят ввести N так продолжается пока мы не введем правильный N
     readln(n);
     i:=1; // Установка флага - ДА
     untill  (n>=1) and (n<100); // Ограничения N
     writeln('Ваше множество:');// Вывод множества;
     for i:=n to 99 do // из условия следует что числа будут в диапазоне от 1 до 99 т.к они натуральные и двухзначные 
     begin
         s:=i mod 11; //Условие при котором Цифры повторяются  т.е. делятся на 11
         if (s<>0) then write(i,'; '); // Проверка условия выше;
     end;
     writeln;
     write('Повторить программу?(1-Да, 0-Нет)-');// Предложение о том сделать ли еще раз программу
     read(i);
     if (i=1) then goto L1; // опять же установка флага и переход к метке L1; если же условие не выполняется, то конец программы
end.
Konstantinovna1936

использовать Чертежник

алг

нач

сместиться на вектор (2,0)

опустить перо

сместиться на вектор (0,1)

сместиться на вектор (-1,0)

сместиться на вектор (0,1)

сместиться на вектор (2,0)

сместиться на вектор (0,-1)

сместиться на вектор (1,0)

сместиться на вектор (0,1)

сместиться на вектор (3,0)

сместиться на вектор (0,3)

сместиться на вектор (3,0)

сместиться на вектор (0,-3)

сместиться на вектор (1,0)

сместиться на вектор (0,4)

сместиться на вектор (3,0)

сместиться на вектор (0,-4)

сместиться на вектор (1,0)

сместиться на вектор (0,8)

сместиться на вектор (2,0)

сместиться на вектор (0,-2)

сместиться на вектор (-1,0)

сместиться на вектор (0,-8)

сместиться на вектор (-3,0)

сместиться на вектор (0,4)

сместиться на вектор (-1,0)

сместиться на вектор (0,-4)

сместиться на вектор (-3,0)

сместиться на вектор (0,4)

сместиться на вектор (-1,0)

сместиться на вектор (0,-4)

сместиться на вектор (-2,0)

сместиться на вектор (0,1)

сместиться на вектор (-1,0)

сместиться на вектор (0,-1)

сместиться на вектор (-3,0)

поднять перо

сместиться в точку (15.9,9)

опустить перо

сместиться в точку (16,9.1)

сместиться в точку (16.1,9)

сместиться в точку (16,8.9)

сместиться в точку (15.9,9)

поднять перо

сместиться в точку (0,0)

кон


ИСПОЛЬЗУЙТЕ среду графического исполнителя, запрограммируйте рисование следующей фигуры: На проверку

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Ручка стоила k рублей. первого сентября стоимость ручки увеличилась ровно на p процентов. определите, сколько ручек можно купить на s рублей после подорожания. программа получает на вход три целых положительных числа. первое число k – стоимость ручки в рублях до подорожания. второе число p – величина подорожания ручки в процентах. третье число s – имеющаяся сумма денег. числа k и s не превосходят 107 , число p не превосходит 100. ручка стоила 33 рубля. после подорожания на 5 % ручка будет стоить 34 рубля 65 копеек (заметим, что, поскольку первоначальная цена ручки была целым числом рублей, после подорожания стоимость ручки будет выражаться целым числом рублей и копеек на 100 рублей после подорожания можно купить 2 ручки. решите на python
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Zhilinoe134
Vladimirovich1898
Бочкарева Горохова1652
fednik3337923
Анатольевич-Фатима
Джулия
ANDREY261965
xsmall1
dima-pashkovec
Оксана Анна
kryshtall2276
nastya3213868
teashop
Мария Кашихина
Panei
▲