Minchenkova
?>

Паскаль. вова попал на космическом корабле на бесконечную плоскую планету в точку с координатами (x1, y1 вова, кораблем, имеет возможность за одну секунду телепортироваться из точки (x, y) в одну из точек (x+c, y+c), (x+c, y-c), (x-c, y+c), (x-c, y-c), где c - произвольное натуральное число, которое можно изменять на каждом ходу. требуется написать программу, которая определит, через какое минимальное время вове удастся достичь точки (x2, y2). входные данные входной файл input.txt содержит в первой строке числа x1, y1, во второй – x2, y2. все числа целые от нуля до 106. точки (x1, y1) и (x2, y2) не . выходные данные выходной файл output.txt должен содержать одно число – минимальное время телепортации. если такая телепортация невозможна, то вывести 0.

Информатика

Ответы

Yekaterina358
1. Заметим, что такими манипуляциями нельзя поменять чётность произведения xy, где (x, y) - текущие координаты корабля. Если угодно, можно представить бесконечное поле для шахмат, корабль ходит как слон - только по диагонали, поэтому цвет поля не меняется.
2. Естественно "развернуть" координаты так, чтобы "горизонтальное" и "вертикальное" направления были вдоль диагоналей. Это делается путем преобразования x' = x + y, y' = x - y.
3. В новых координатах корабль может ходить по горизонтали и вертикали, при этом в любую достижимую точку он придет не более чем за 2 шага. За 1 шаг он придет, если стоит в той же горизонтали или вертикали.
4. Для простоты сдвинем начало координат в начальную точку, тогда точка назначения будет иметь координаты x' = (x2 - x1) + (y2 - y1), y' = (x2 - x1) - (y2 - y1)

Решение, PascalABC.NET:

begin
  var inf := OpenRead('INPUT.TXT');
  var outf := OpenWrite('OUTPUT.TXT');
  var x1, x2, y1, y2: longint;
  read(inf, x1, y1, x2, y2);
  if (x1 * y1 - x2 * y2) mod 2 = 0 then
  begin
    (x2, y2) := ((x2 - x1) + (y2 - y1), (x2 - x1) - (y2 - y1));
    if x2 * y2 = 0 then
      write(outf, 1)
    else 
      write(outf, 2);
  end
  else
    write(outf, 0);
  close(inf);
  close(outf);
end.
ВостриковаСтародубцева1980

Автор

100 слов для студента

Абзац

100 слов для студента

Аудитория

100 слов для студента

100 слов для студента

Белорусский

100 слов для студента

Беседа

100 слов для студента

Беседовать

100 слов для студента

Библиотека

100 слов для студента

Брать

100 слов для студента

Будущий

100 слов для студента

Важный

100 слов для студента

Вариант

100 слов для студента

Ведомость

100 слов для студента

Век

100 слов для студента

Великий

100 слов для студента

Вернуть

100 слов для студента

Вести

100 слов для студента

Взять

100 слов для студента

Внимание

100 слов для студента

Вопрос

100 слов для студента

Время

100 слов для студента

Объяснение:

askorikova
Для всех заданий воспользуемся формулой N=2^i? где N -количество цветов, а i -количество бит на 1 пиксель.
Задача 1.
N=2^4=16 цветов.

Задача 2.
N=224=2^i, поскольку для кодирования 128 цветов необходимо 7 бит, а для кодирования 256 цветов -8 бит, выбираем большее число, то есть 8 бит или 1 байт.

Задача 3.
65536 это 2^16⇒требуется 16 бит или 2 байта.

Задача 4.
1. Узнаем общее количество пикселей 1280*1024=1310720
2. Полученное число умножаем на глубину цвета 1310720*32=41943040 бит = 41943040/8 = 5242880 байт = 5242880/1024 = 5120 кб =5120/1024 = 5 Мб
ответ: 5 Мб

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль. вова попал на космическом корабле на бесконечную плоскую планету в точку с координатами (x1, y1 вова, кораблем, имеет возможность за одну секунду телепортироваться из точки (x, y) в одну из точек (x+c, y+c), (x+c, y-c), (x-c, y+c), (x-c, y-c), где c - произвольное натуральное число, которое можно изменять на каждом ходу. требуется написать программу, которая определит, через какое минимальное время вове удастся достичь точки (x2, y2). входные данные входной файл input.txt содержит в первой строке числа x1, y1, во второй – x2, y2. все числа целые от нуля до 106. точки (x1, y1) и (x2, y2) не . выходные данные выходной файл output.txt должен содержать одно число – минимальное время телепортации. если такая телепортация невозможна, то вывести 0.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

garunkhachatryan
eoils-info
Sukharev-Achkasov
Pilotmi247074
Svetlana1884
Sergei1805
homeo85
Кочугурова
janetp
erere4443
tribunskavictory
webotryvclub21
krtatiana69
Gavrilova2527
Светлана константин