ivanandrieiev1984268
?>

Спо паскалю надо люди выручите . напишите программу, которая вводит значения трех переменных, a, b, c, типаword и выводит их сумму. каждое значение следует вводить с отдельной строки. результат также помещается на отдельнуюстроку. при составлении программы обеспечьте приглашение к вводу данных.

Информатика

Ответы

Yevsyukov1697

рrogram summa;

var s, a, b, c : word;

            write('введите a - > '); readln(a);

            write('введите b - > '); readln(b);

            write('введите с - > '); readln(c);

            s=а+в+с

            write(' сумма равна ',s);

            readln

в принципе все, должно быть правильно

 

palchiknr

program summa;

var s, a, b, c : word;

begin

            write('введите a - > '); readln(a);

            write('введите b - > '); readln(b);

            write('введите с - > '); readln(c);

            s: =a+b+c;

            write(' сумма равна ',s);

            readln

end.

olyafom1234
А) 3  девочки могут сесть на 3 стула 6-ю разными способами и так же 3 мальчика могут сесть на 3 стула 6-ю способами арифметически эту закономерность можно записать как 1*2*3=6 6*6=36 способов всего. б) по той же закономерности получается 1*2*3*4*5=120 разных способов рассаживания отдельно мальчиков и отдельно девочек. всего способов: 120*120 = 14400 формулы  комбинаторики:   формула размещения с из n по m = n! /(n-m)! для размещения из 3 по 3 =  3! /(3-3)! =3! /1! =3! =1*2*3=6 для размещения из 5 по 5 = 5! /(5-5)! =5! /1! =5! =1*2*3*4*5=120
adhotel
// pascalabc.net 3.2, сборка 1353 от 27.11.2016 // внимание! если программа не работает, обновите версию! begin   var n: =10;   var a: =arrrandom(n,1,99); a.println;   var d: =100;   var i1,i2: integer;   for var i: =0 to n-2 do       for var j: =i+1 to n-1 do begin           var dd: =abs(a[i]-a[j]);           if dd< d then begin d: =dd; i1: =i; i2: =j end           end;   writeln('элементы ',i1+1,', ',i2+1) end. пример 47 55 18 58 16 77 43 95 13 86 элементы 3, 5

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Спо паскалю надо люди выручите . напишите программу, которая вводит значения трех переменных, a, b, c, типаword и выводит их сумму. каждое значение следует вводить с отдельной строки. результат также помещается на отдельнуюстроку. при составлении программы обеспечьте приглашение к вводу данных.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

euzdenova
upmoskovskiy
suny84
Vyacheslavovna240
Natalya
arutchevben64
maksimforyou20
novkatrina
oksanashabanovadc3197
Хабарьева Андрей1056
Какой сигнал называют дискретным?
tyrenumberone
echervyakov
osandulyak
Zolotnik974620
DJXEz80