ОбъяснениеВ языке Паскаль описатель типа integer требует выделить под каждую переменную или элемент массива количество памяти, необходимое для размещения чисел из диапазона , т.е. отвести не менее двух байт, что и выполнялось в ранних системах, таких как Turbo Pascal, созданных во времена дорогой оперативной памяти. В современных разработках может выделяться и большее количество байт, например, в PascalABC.Net под переменную типа integer отводится 4 байта.
Описатель array [1..20] of integer требует отвести память под 20 элементов типа integer, следовательно, если говорить о минимально необходимом количестве байт, то ответом будет в) 20, 40.
А для PascalABC.Net ответ должен быть 20, 80
Подробнее - на -
Поделитесь своими знаниями, ответьте на вопрос:
Составьте программу заполняет массив случайными целыми числами в диапазоне от 0 до10 и находит максимальный элемент массива среди элементов с четными индексами
var a:array [1..n] of integer;
i,max: integer;
begin
randomize;
for i:=1 to n do
begin
a[i]:=random (10);
write(a[i],' ')
end;
writeln;
max:=a[1];
for i:=1 to n do if (i mod 2 =0) and (max<a[i])
then max:=a[i];
writeln (max)
end.