saytru5850
?>

Лёгкая по паскалю! составьте программу, которая позволяет заменить в строке s слово t1 на слово t2. строку s и слова t1 и t2 введите с клавиатуры. пример ввода: на небе появилась туча. туча луна пример вывода: на небе появилась луна.

Информатика

Ответы

elenaperemena8
Var
  s, t1, t2, st: string;
  i: integer;
begin
  readln(s);
  readln(t1);
  readln(t2);
  if pos(t1, s) <> 0 then
    i := pos(t1, s);
  st := copy(s, 1, i - 1);
  st := st + t2;
  st := st + copy(s, i + length(t1), length(s));
  writeln(st);
  readln;
end.
romolga3580
1.  Словарь в компьютере или другом электронном устройстве.
2. Если переводить текст например с ангийского то некоторые слова надо переставлять и это иногда затрудняет, но всё же можно разобраться.
3. Словарь переводит отдельные слова в именительном падеже, а система перевода переводит слова, если встречаются выражения - переводит их не отдельными словами, а целиком. Кроме того, система перевода выставляет нужные падежи, правильно выставляет слова и старается подобрать набор слов наиболее литературно, но не всегда удачно.
kozak8824

1)2^2=4

2)как я понимаю, это некоторые типы имеющие ключ и значение в одной связке. Набор таких пар будет словарем

3)не знаю какие из них дополнительные.

*сложности языка, падежи, окончания,времена

*пордок слов в предложениее

*контекстный или литературный перевод, чтоб не терялось значение написаного

4)подразумевается электронный переводчик?

все перечисленное в п3, человек то может а машина нет

5)потому что это рисунок, а не текст

6)перевод картинки в текстовую информацию, если этот текст там конечно есть

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Лёгкая по паскалю! составьте программу, которая позволяет заменить в строке s слово t1 на слово t2. строку s и слова t1 и t2 введите с клавиатуры. пример ввода: на небе появилась туча. туча луна пример вывода: на небе появилась луна.
Ваше имя (никнейм)*
Email*
Комментарий*