ddobrov32133
?>

Кто может python ! даны координаты двух различных шахматных полей x1, y1, x2, y2 (целые числа в диапазоне 1-8 проверьте, может ли ладья перемещаться с одного поля на другое за один ход

Информатика

Ответы

proea

На скриншоте ===========

Стандартная шахматная нотация через пробел (a2 a4 ) для ввода тоже работает )) ну и 35 37 тоже....


Кто может python ! даны координаты двух различных шахматных полей x1, y1, x2, y2 (целые числа в диа
tobolenecivanov1675

Задание 2, 3 во вложении

Объяснение:

Задание 1.

Сначала вводятся переменные b и с через пробел.

Мы вводим сначала с, оно равно 205, и затем b, оно равно 204.

затем идет условие.

Если с>b или b mod 2=0

Если 205>204 или

b mod 2=0 - это означает, число b кратно 2, то есть при делении на 2 оно должно дать 0.

В нашем случае 204/2=102 , то есть число 204 кратно 2, оно поделилось на него без остатка.

Первое и второе условие сработало, а значит выполняется следующее:

a:=b+2;

То есть в переменной а мы к b прибавляем 2. И у нас выходит:

a:=204+2=206

Условие иначе у нас не работает, поэтому выводим:

Writeln(a);

Программа выведет число а

206.


1)Чему равно значение а после выполнения программы, если с=205 b=204 Var a,b,c: integer; Begin Read
1)Чему равно значение а после выполнения программы, если с=205 b=204 Var a,b,c: integer; Begin Read
mvolkov8
// PascalABC.Net 3.0, сборка 1052
const
  Rus=['А'..'Я'];
var
  s:string;
  i,k,t:integer;
  c,c1,tc,sc:char;
  f:array['А'..'а'] of byte; // 'а' - это для 'Ё'
  ch:array['А'..'а'] of char;
begin
  Write('Введите строку: '); Readln(s);
  for c:='А' to 'а' do begin f[c]:=0; ch[c]:=c end;
  k:=0;
  for i:=1 to Length(s) do begin
    c:=UpCase(s[i]);
    if c in Rus then begin Inc(f[c]); Inc(k) end
    else
      if c='Ё' then begin Inc(f['а']); Inc(k) end;
  end;
  Writeln('Количество русских букв равно ',k);
  { сортировка массива со счетчиком количества букв }
  for c1:='А' to Pred('а') do
  for c:='А' to Pred('а') do
    if f[c]<f[Succ(c)] then begin
      t:=f[c]; tc:=ch[c]; sc:=Succ(c);
      f[c]:=f[sc]; ch[c]:=ch[sc];
      f[sc]:=t; ch[sc]:=tc
    end;
  Writeln('Частота встретившихся букв');
  c:='А';
  while (c<='а') and (f[c]>0) do begin
    if ch[c]='а' then ch[c]:='Ё';
    Writeln(ch[c],' - ',f[c]);
    Inc(c)
  end;
end.

Тестовое решение:
Введите строку: Когда я был парнишкой, носил я брюки клёш
Количество русских букв равно 33
Частота встретившихся букв
К - 4
И - 3
Л - 3
О - 3
А - 2
Б - 2
Н - 2
Р - 2
Ш - 2
Я - 2
Г - 1
Д - 1
Й - 1
П - 1
С - 1
Ы - 1
Ю - 1
Ё - 1

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Кто может python ! даны координаты двух различных шахматных полей x1, y1, x2, y2 (целые числа в диапазоне 1-8 проверьте, может ли ладья перемещаться с одного поля на другое за один ход
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

morozov1605
dfyurst708
kristina
Андрей
info49
qwert28027170
irohmichaelchikaodiri
sarbaevmax
ksen1280
Ye.Vadim
Vitalevna
patersimon1
iivanovar-da
Анатольевич-Митюшин
nsmmkrtchyan
▲