Fedorov1283
?>

Лёгкая по паскалю! , ! составьте программу которая позволяет удалить второе слово строки s. строку s, состоящую из 2 слов, разделённых пробеламі, введите с клавbатуры.

Информатика

Ответы

vvk2008
Var s: string; x,i: byte;
begin
writeln('Введите строку:');
readln(s);
for i:=2 to length(s) do begin
  if s[i]=' '
    then begin
      x:=i+1;
      while (s[x]<>' ') and (x<length(s)) do begin
        delete(s,x,1);
      end;
      delete(s,x,1);
      break;
    end;
end;
writeln(s);
end.

Пример 1:
мама мыла
мама 
Пример 2:
Мама мыла раму
Мама раму

PS: считается, что строка не начинается с пробела и не может быть два пробела подряд
Кочугурова
Сын князя ярослава всеволодовича, внук великого князя владимирского всеволода iii большое гнездо. правил в переяславле (ныне переславль-залесский), а также неоднократно занимал княжеский престол великого новгорода.в 1235 г. александр был при отце во время битвы на реке амовже (эмбах), где рать разгромила рыцарей ордена меченосцев. 15 июля 1240 г. он одержал свою первую победу, в честь которой и получил прозвание невский: на реке ижоре, в неву, разбил шведов. вскоре после этого новгородцы принудили александра оставить княжение в их городе и удалиться в отчий переяславль. однако через несколько месяцев на северные земли напали рыцари из ливонии; их благословил сам папа римский. был захвачен изборск, затем псков. новгородцы оказались вынуждены обратиться к александру за . в начале 1242 г. исход войны великого новгорода и тевтонского ордена определился. александру удалось освободить псков, где, по сведениям ливонской хроники, погибли 70 знатных рыцарей, а 6 взяты в плен. затем князь повёл войска к чудскому озеру. 5 апреля на льду состоялось решающее сражение, вошедшее в как ледовое побоище. сознательно позволив немцам, использовавшим традиционное для рыцарского воинства того времени построение клином — свиньёй, потеснить пехоту в центре, александр фланговыми ударами дружинной конницывзял противника в кольцо и наголову его разгромил.в 1246 г. в далёкой монголии умер отец александра ярослав всеволодович, пребывавший тогда при дворе великого хана монголов гуюкхана. печальная весть достигла сыновей лишь через год. теперь в монголию пришлось отправиться александру с братом андреем. результатом двухлетнего путешествия (1247—1249 гг.) стало владимирского княжения андрею, а киева — александру, куда, впрочем, он так и не поехал, оставшись в новгороде.андрей, войдя в союз со своим тестем — галицким и волынским князем даниилом галицким, которого готовы были поддержать литва, польша, венгрия, тевтонский орден и папа иннокентий, попытался создать коалицию против золотой орды. однако грандиозный план был пресечён монголами, в 1252 г. обрушившими на русь так называемую неврюеву рать (по имени ордынского царевича неврюя, возглавившего поход).поражение андрея и его бегство за рубеж, в швецию, открыли александру путь к великокняжескому престолу. в соответствии с ханским ярлыком в 1252 г. он стал великим князем владимирским. последнюю поездку в золотую орду александр предпринял, чтобы спасти города от ордынского погрома, после того как в 1261—1262 гг. во владимире, суздале, ростове, ярославле, переяславле жители перебили ордынских сборщиков дани.возвращаясь из орды, князь заболел и 14 ноября 1263 г. скончался в городце близ нижнего новгорода, приняв перед смертью схиму. похоронен в храме рождества богородицы во владимире.
Immortal3331
Александр ярославич невский (1221 - 1263) – князь новгородский, киевский, владимирский. был сыном переяславльского князя. в 1225 году в биографии александра невского произошло посвящение в воины. в 1228 году поселился в новгороде, а в 1230 году стал князем новгородских земель. в 1236 году, после отъезда ярослава стал самостоятельно защищать земли от шведов, ливонцев, литовцев. в 1239 году александр женился на дочке брячислава полоцкого, александре. в июле 1240 года состоялась знаменитая невская битва, когда александр напала на шведов на неве и победил. когда же ливонцы взяли псков, тёсов, подобрались к новгороду, александр снова разбил врагов. после этого в своей биографии александр невский напал на ливонцев 5 апреля 1242 года (ледовое побоище на чудском озере). князь на протяжении 6 лет отражал нападения врагов. затем он уехал из новгорода во владимир. когда умер ярослав, святослав, александр невский получил власть в киеве. за всю свою жизнь невский не проиграл ни одного сражения. он был талантливым дипломатом, полководцем, смог защитить русь от многих врагов, а также предотвратить походы монголо-татар. александр невский имел четырех сыновей: василия (1245 – 1271, новгородский князь), дмитрия (1250 – 1294, новгородский, переяславский, владимирский князь ), андрея (1255 – 1304, костромской, владимирский, новгородский, городецкий князь), даниила (1261 – 1303, московский князь), а также дочь евдокию.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Лёгкая по паскалю! , ! составьте программу которая позволяет удалить второе слово строки s. строку s, состоящую из 2 слов, разделённых пробеламі, введите с клавbатуры.
Ваше имя (никнейм)*
Email*
Комментарий*