raa-0485428
?>

На си: Заданы массивы чисел Х [0.. n] и Y[0..m]. Написать программу, определитьзначение переменной z. Исходные данные и результат напечатать с пояснительнымтекстом. Решение задачи оформить с использованием функций. Значения n и m задавать склавиатуры, значения элементов массива задавать случайным образом.В формулах расчета y использованы следующие условные обозначения:А1(Х) - сумма элементов массива Х;А2(Х) - сумма положительных элементов массива Х;А3(Х) - сумма отрицательных элементов массива Х;А4(Х) - количество нулевых элементов массива Х;А5(Х) - сумма максимального и минимального элементов массива Х;А6(Х) - среднее арифметическое значение элементов массива Х;А7(Х) - произведение абсолютных значений элементов массива Х;А8(Х) - корень квадратный из суммы положительных элементов массива Х;А9(Х) - натуральный логарифм из суммы абсолютных значений элементов массива Х;А10(Х) - сумма корней квадратных из положительных элементов массива Х;М1(Х) - количество элементов массива Х, значения которых меньше А1;М2(Х) - количество отрицательных элементов массива Х;М3(Х) - количество элементов массива Х, значения которых больше А6;М4(Х) - количество элементов массива Х, значения которых меньше А6;М5(Х)- количество элементов массива Х, значения которых больше А8.

Информатика

Ответы

snabdonm501
#include <iostream>
using namespace std;
int main() {
        int mat[3][3];
        int k;
        int size=0;
        int * arr=0;
        for(int i=0;i<3;i++){
                for(int j=0;j<3;j++){
                       cin>>mat[i][j];
                          if (mat[i][j]>0){
                             arr=(int*)realloc(arr,sizeof(int)*(++size));
                             arr[size-1]=mat[i][j];
                                             }
                                           }
                                    }
                  for(int i=0;i<size;i++){
                  cout<<arr[i];
                  }
               delete arr;
               cin.get();
               cin.get();
              return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На си: Заданы массивы чисел Х [0.. n] и Y[0..m]. Написать программу, определитьзначение переменной z. Исходные данные и результат напечатать с пояснительнымтекстом. Решение задачи оформить с использованием функций. Значения n и m задавать склавиатуры, значения элементов массива задавать случайным образом.В формулах расчета y использованы следующие условные обозначения:А1(Х) - сумма элементов массива Х;А2(Х) - сумма положительных элементов массива Х;А3(Х) - сумма отрицательных элементов массива Х;А4(Х) - количество нулевых элементов массива Х;А5(Х) - сумма максимального и минимального элементов массива Х;А6(Х) - среднее арифметическое значение элементов массива Х;А7(Х) - произведение абсолютных значений элементов массива Х;А8(Х) - корень квадратный из суммы положительных элементов массива Х;А9(Х) - натуральный логарифм из суммы абсолютных значений элементов массива Х;А10(Х) - сумма корней квадратных из положительных элементов массива Х;М1(Х) - количество элементов массива Х, значения которых меньше А1;М2(Х) - количество отрицательных элементов массива Х;М3(Х) - количество элементов массива Х, значения которых больше А6;М4(Х) - количество элементов массива Х, значения которых меньше А6;М5(Х)- количество элементов массива Х, значения которых больше А8.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Orestov563
Маргарита794
vikapar2646
kim-1971
armusaeff
VSpivak3122
cafemgimo
nnbeyo
gubernatorov00
Станислав Валерий1696
vova00831
ievlevasnezhana7
mail2017
Владислав-Аветисян217
ribanina