Larisa-Andrei
?>

Найти все натуральные числа а, b и с из интервала от 1 до 20, для которых выполняется равенство: a+b=c (составить программу на языке программирования)

Информатика

Ответы

timonina29
Begin
for a:= 1 to 20 do
for b:= 1 to 20 do
for c:= 1 to 20 do
begin
if a*a+b*b=c*c then
writeln(a:4,b:4,c:4);
end;
end.
in-1973

ответ:

номер 1-интернет - всемирная паутина, которая хранит в себе тонны информации. он заменяет нам любой источник информации и облегчает понимание.

газеты/журналы - письменные, или же стандартные способы получения информации на бумаге.

телевидение - самый удобный источник информации. содержит в себе и картинку, и звук, и приятную визуализацию.

постеры/афиши - бумажки расклеенные по городу или же огромные постеры размещенные на зданиях. привлекает внимание, тем самым увеличивает число интересующихся.

радио - звуковая информация, уже перестает быть актуальной. в основном, радио - это не новости, а что-то более развлекательное.

номер 2-к примеру, кто-то описывает картину на бумаге (повествованием), тем самым переводит графическую информацию в текстовую. рассказывает вслух - уже в звуковую. и т. д.

номер 3-написание дипломного  проекта  из  своего  же  курсового,  время  прошло  законы  изменились  и  теперь  за  одни  и  теже  административные  проступки  другие  наказания, но  дабы  не  писать с  нуля все  это  лучше  обработать  свой  же  курсовик  соответственно  изменив  его  содержание

номер 4-молекула днк  

              оптические носители  

              египитские папирусы  

              бумага

             

glebovaludok

#include <iostream>

#include <string>

using namespace std;

string fn(unsigned value, unsigned base) {

static string box;

if (!value) {

auto x = box;

box.clear();

return string(x.rbegin(), x.rend());

}

box += to_string(value % base);

value /= base;

return fn(value, base);

}

int main() {

unsigned base, value;

cin >> base >> value;

auto result = fn(value, base);

cout << value << "(10)=" << result << "("<< base << ")\n";

system("pause > nul");

}

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Найти все натуральные числа а, b и с из интервала от 1 до 20, для которых выполняется равенство: a+b=c (составить программу на языке программирования)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mbudilina
bereza81
a1rwalk3r
YekaterinaAbinskov
magazin-71
Vos-sv
reception
yanermarina87
slastena69678
arturnanda803
membuksdk
simplexsol
КалюкМарасанов1026
kuliba
Сергеевич1386