YekaterinaAbinskov
?>

Написать программу для решения этой на паскале: "хватит ли n= 180 штук кафельной плитки шириной a= 0, 2 м шириной b=0, 3 м для покрытия пола в помещении площадью s=12 м²? "

Информатика

Ответы

bsi771184
Var a,b,s:real; n:integer;
begin
n:=180;
s:=12;
a:=0.2;
write('Ширина ',a:3:1,' - ');
if a*a*n>=s then writeln('Yes')
else writeln('No');
b:=0.3;
write('Ширина ',b:3:1,' - ');
if b*b*n>=s then writeln('Yes')
else writeln('No');
end.

Результат:
Ширина 0.2 - No
Ширина 0.3 - Yes
Александрович Андреевна

Возьмём допустим винлокер

Winlock (Винлокер) — семейство вредоносных программ, блокирующих или затрудняющих работу с операционной системой, и требующих перечисление денег злоумышленникам за восстановление работо компьютера, частный случай Ransomware (программ-вымогателей).

Чаще всего использует системный реестр для автозапуска и других пакостей. Удалить более менее легко в безопасном режиме. Если винлок брокирует запуск даже в безопасном режиме, запускаемся в безопасном режиме с командой строкой, пишем explorer и действуем как обычно. Вроде всё сказал, билдеры и билды можно найти в инете

mariy-inkina8

Если СС системы счисления, то:

Двоичная:

126 = 1111110

Переводим целую часть 12610 в 2-ую систему последовательным делением на 2:

126/2 = 63, остаток: 0

63/2 = 31, остаток: 1

31/2 = 15, остаток: 1

15/2 = 7, остаток: 1

7/2 = 3, остаток: 1

3/2 = 1, остаток: 1

1/2 = 0, остаток: 1

126 = 1111110

Обратно:

Переводим 1111110 в десятичную систему:

1111110 = 1·2⁶+1·2⁵+1·2⁴+1·2³+1·2²+1·2¹+0·1 = 126

Восьмеричная:

126 = 176

Переводим целую часть 126 в 8-ую систему последовательным делением на 8:

126/8 = 15, остаток: 6

15/8 = 1, остаток: 7

1/8 = 0, остаток: 1

126 = 176

Обратно:

Переводим 1768 в десятичную систему:

176 = 1·8²+7·8¹+6·1 = 126

Шестнадцатиричная:

126 = 7E

Переводим целую часть 126 в 16-ую систему последовательным делением на 16:

126/16 = 7, остаток: 14, 14 = E

7/16 = 0, остаток: 7

126 = 7E

Обратно:

Переводим 7E в десятичную систему:

7E = 7·16¹+14·1 = 126

Как-то так)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу для решения этой на паскале: "хватит ли n= 180 штук кафельной плитки шириной a= 0, 2 м шириной b=0, 3 м для покрытия пола в помещении площадью s=12 м²? "
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

steam22-9940
Vyacheslavovich Mikhailovich1421
nevzorova
atvkaprolon
osherbinin
a8227775
Bolshakova Shigorina
ss2911
es196
Akopovich802
Ushakova Sakhno
mkrtchyananaida6995
Shago
adel25159
delfa-r6289