Popova838
?>

Написать программу, которая выводит на экран таблицу стоимости яблок в диапазоне от 100 г до 1 кг с шагом 100. стоимость за один кг взять произвольно (используя цикл с параметром

Информатика

Ответы

polotovsky
Название по-моему называется: Excel, точно не знаю, если что извените...
Игоревна Худанов1150
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
const
  m = 10;

var
  t: array[1..m] of integer;
  i, n, nm, sm: integer;

begin
  //Заполняем массив сл.числами и подсчитываем
  //количество элементов и среднее арифметическое
  //согласно условию задачи
  for i := 1 to m do
  begin
    t[i] := random(-20, 20);write(t[i]:4);
    if (i > 1) and (i <= m) then
      if t[i] > t[i - 1] then n := n + 1
      else if t[i] < t[i - 1] then begin
        sm := sm + t[i];nm := nm + 1;
      end;
  end;
  writeln;
  writeln('число элементов больших предыдущего = ', n);
  writeln('ср. арифметическое элементов меньших предыдущего = ', sm / nm);  
 
end.

Тестовое решение:
    6  13  19   8 -19 -11 -20 -15 -19 -13
число элементов, больших предыдущего = 5
среднее арифметическое элементов, меньших предыдущего = -12.5
donliolik
1.Что общего у пиктограммы и символа? В чем между ними различия?

Общее - оба являются небольшими графическими объектами

Различия - пиктограмма или иконка используется как растровый графический объект и страдает от маштабирования, но при этом может иметь много цветов. Обычно используется как подсказка на кнопку с некой командой (напр. сохранить, копировать, вставить)

Символ является частью некого шрифта и потому нарисован в векторной графике, не искажается при маштабировании, но может быть лишь одного цвета. Может иметь несколько вариантов начертания - курсив, жирный и тд. Используется так же как текст

В последнее время микрософт ввели новый шрифт для пиктограм, окончательно сроднив оба элемента.  
2. Что такое знаковая система? Попытайтесь описать русский язык как знаковую систему? Опишите десятичную систему счисления как знаковую систему.

Знаковая система - это система определения неких определенных знаков как определенные понятия. 

Язык - знаковая система сама по себе. Например есть обьект красно-желтый, сладкий, для него придумали название "яблоко". Доугой назвали "абрикос" и тд. Тут все легко, сложнее с абстрактными понятиями и действиями, чувствами. Еще примечательно что оперировать можно лишь внутри понятий определенных языком.
Весьма трудно увидель то чего нет в языке. Это уже часть управления
С десятичной системой думаю и так все ясно. Два яблока это  "2", семь это "7". Просто так обозначили

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая выводит на экран таблицу стоимости яблок в диапазоне от 100 г до 1 кг с шагом 100. стоимость за один кг взять произвольно (используя цикл с параметром
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

serov555zaq5
vsemvsego306
rimmaskis
Бражинскене_Алексей
jenko87
serg1976g
fotomuha1
myudanova631
tboychenko
Bolshakova Shigorina
kurmaleeva
Stepanovich_Makarov
olimov
kmr495270
КОРМИЛИЦЫНА