vypolga1347
?>

40 ! есть добрые люди, заранее : составьте программу, проверяющую, верно ли утверждение, что введенное вами целое число делится без остатка на 3.

Информатика

Ответы

pedalplanet
program Checker; uses crt; var Digit:integer; begin   write('Enter digit:');   readln(Digit);   if Digit mod 3=0 then writeln('This digit is divisible by 3!')   else writeln('This digit is not divisible by 3!');   readln; end.
rs90603607904
1)Все просто \frac{32*1024*8}{4096} = \frac{x}{256}
Почему так? Все просто в левой части уравнения приведена формула времени за которое передастся файл размером 32*1024*8 (переводим в биты) и справа также приведена формула времени передачи файла размером x со скоростью 256 б/с. приравниваем одно к другому дальше выражаем x и просто считаем
получится x=16384 бита или 2048 байта.
2)\frac{ 2^{20} }{8*1024} = \frac{ 2^{20} }{ 2^{3}* 2^{10}} = \frac{ 2^{20} }{ 2^{13}} }= 2^{7} =128 Кбайт (надеюсь обьяснять как переводить из бит в байты Кбайты и т.д. не надо?)
3) также как и раньше сначала переводим всё в биты
375 Кбайт=375*1024*8 бит
и расчитываем по формуле v=s/t (аналогия из математики)
v= \frac{375*1024*8}{24} =128000 бит в секунду
4)также как и раньше только теперь t=s/v
\frac{500*1024*8}{256000} =16 секунд
5)точно такая же как и раньше только теперь s=vt ну и перевести в Кбайты не забудь s= \frac{256000*16}{8*1024} =500 Кбайт
Konchenko1980
1. 262144 бит = 262144/8 байт = 32768 байт = 32768/1024 Кбайт = 32 Кбайт 
2. 16384 бит = 16384/8 байт = 2048 байт = 2048/1024 Кбайт = 2 Кбайт 
3. 131072 бит = 131072/8 байт = 16384 байт = 16384/1024 Кбайт = 16 Кбайт
4. 1/4 Кбайт = 1024/4 байт = 256 байт = 8*256 бит = 2048 бит
5. 227 бит = 227/8 байт = 227/(8*1024) Кбайт = 227/(8*1024*1024) Мбайт ≈ 0,000027 Мбайт
6. 10 Кбайт = 10*1024 байт = 10240 байт = 10240*8 бит = 81920 бит = 81920/1000 Кбит = 81,92 Кбит
7. 2048 бит = 2048/1000 Кбит = 2,048 Кбит
8. 2 Кбит = 2*1000 бит = 2000/8 байт = 250 байт

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

40 ! есть добрые люди, заранее : составьте программу, проверяющую, верно ли утверждение, что введенное вами целое число делится без остатка на 3.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

elegiy
tolyan791
Екатерина655
Irina-Tunyan
Anastasiya
olgalooo
Lesya
SlavaA99
геннадиевна2001
slitex
suxoruchenkovm171
ekater01806
msangelika1010
hbqhzwtd
falileevas