tata-novik
?>

1. составить программу: если сумма двух чисел положительна, то определить их разность, а в противном случае - произведение (ветвление написать программу на

Информатика

Ответы

palmhold578
Var
  a, b: integer;
 begin
  readln(a, b);
  if(a + b > 0) then write(a - b)
  else write(a * b);
end.
Alekseeva_Khlistov

1.

const

  quantity = 18;

var

  res, d: integer;

function sum(a, b: integer): integer;

begin

  sum := a + b;

end;

begin

  writeln('Введите число D: ');

  readln(d);

  res := sum(d, quantity);

  writeln(res);

end.

2.

const

  x = 1.0;

var

  square, radius, Pi_num: real;

function ArcTan(X: Real): Real;

begin

  ArcTan := (sin(x) / cos(x));

end;

function ray(square: real): real;

begin

  ray := sqrt(square / Pi_num);

end;

begin

  Pi_num := ArcTan(x) * 2;

  writeln('Введите площадь окружности: ');

  readln(square);

  radius := ray(square);

  writeln(radius);

end.

Pirogovskii695
Type  mas = array[1..8] of integer;
var
  A, F, Q: mas;
  C:array[1..8] of real;
  i: integer;
function M(x,y:real):real;
begin
Result:=(x*x+y*x)/2+sin(x*y)
end;
begin 
clrscr; 
writeln('Массив первый:'); 
for i := 1 to 8 do
  begin
    A[i] := random(10);
    write(A[i]:4);
  end; 
writeln; 
writeln('Массив второй :'); 
for i := 1 to 8 do
  begin
    F[i] := random(10) ;
    write(F[i]:4);
  end; 
writeln; 
writeln('Массив третий :'); 
for i := 1 to 8 do
  begin
    Q[i] := random(10);
    write(Q[i]:4);
  end;
writeln; 
writeln('Массив четвертый:'); 
for i := 1 to 8 do
  begin
    C[i] := M(A[i],F[i])+M(Q[i],F[i])+M(A[i],Q[i]);
    write(C[i]:6:1);
  end; 
writeln;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. составить программу: если сумма двух чисел положительна, то определить их разность, а в противном случае - произведение (ветвление написать программу на
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Sergei248
vusokaya13
mishanay301csfp
ГегамБукреев830
ortopediya
olgalooo
Ольга Сергей1822
satinvova
Мария-Кострыгина175
mshelen732
serkan777
Yelena Dilyara
komarov-dmitriy
kagurkina
mariy-inkina8
▲