mshelen732
?>

Страница видеопамяти 16000 байт. дисплей работает в режиме 320х400 пикселей. сколько цветов может быть в палитре? напишите программу в паскале

Информатика

Ответы

sergeykirushev
Var x,y:integer;
v:longint;
i:real;
x:=320;
y:=400;
v = 128000;
i:= v/(x*y);
writeln('Глубина цвета: ', i);
ooottdi

Объяснение:

#include <iostream>

#include <string>

using namespace std;

int main()

{

setlocale(LC_ALL, "ru");

int d = 0;

string s = "";

cout << "Введите строку:" << endl;

getline(cin, s);

for (int i = 0; i < s.length(); i++)

{

 if (s[i] == 'A')

 {

  s[i] = 'B';

  d++;

 }

 else if (s[i] == 'a')

 {

  s[i] = 'b';

  d++;

 }

 else if (s[i] == 'B')

 {

  s[i] = 'A';

  d++;

 }

 else if (s[i] == 'b')

 {

  s[i] = 'a';

  d++;

 }

}

cout << s << endl

 << d << endl;

}

komarov-dmitriy

#include <iostream>

#include <cctype>

using namespace std ;

int main() {

string s;

int freqs[26] = { 0 };

getline( cin, s );

for (auto c : s) {

if (isalpha(c)) {

freqs[toupper(c) - 'A'] += 1;

}

}

int max = 0;

string out = "";

for (int i = 0; i < 26; i++) {

if (freqs[i] == max) {

out.push_back((char)'A' + i);

} else if (freqs[i] > max) {

out = "";

out.push_back((char)'A' + i);

max = freqs[i];

}

}

cout << out << endl;

cout << max;

return 0;

}

Объяснение:

удачки с сириусом мужик)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Страница видеопамяти 16000 байт. дисплей работает в режиме 320х400 пикселей. сколько цветов может быть в палитре? напишите программу в паскале
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

marimelons795
amramzi
ivshzam
komarov-dmitriy
Klyucharyova
snow8646
aleksandramir90
potapin
aa276568
nelli-bi6
asyaurkova
Светлана
shajmasha
serkan777
apromovich1
▲