rayman777
?>

Составьте программу в паскале которая имитирует движения дельфина или кораблика по волнам. или что-то в этом роде.

Информатика

Ответы

nikomuneskazhu60
program corablik; uses Graph, Crt; var   grDriver: integer;   grMode: integer;   ErrCode: integer;   x,y,y0,a,b: integer;{a,b-переменные для линии моря, чтоб они не зависели от х,у}  procedure more(a,b:integer); begin moveto(0,y0); setcolor(blue); for a:=0 to 680 do{слева направо рисуем синусоиду синего чвета}   begin   b:=y0-round(sin(a*pi/180)*30);{30-коэффициент масштабирования по оси Х, чем больше, тем волна круче}   lineto(a,b);  end; end;  begin   grDriver := Detect;   InitGraph(grDriver, grMode, '..\BGI');   ErrCode := GraphResult;   y0 := 250;   if ErrCode = grOk then   begin     x:=600;     while x>=0 do{лучше использовать цикл while, можно менять величину шага, что тоже влияет на скорость и частоту смены картинки}      begin       cleardevice;       more(a,b);{рисуем волну}       setcolor(white);{устанавливаем цвет кораблика}       y:=y0-40-round(sin(x*pi/180)*30);{движемся по волне}       MoveTo(x - 40, y + 20);       LineTo(x - 20, y + 40);       LineTo(x + 20, y + 40);       LineTo(x + 40, y + 20);       LineTo(x - 40, y + 20);       MoveTo(x + 15, y + 20);       LineTo(x + 15, y - 40);       LineTo(x - 20, y + 20);       LineTo(x + 15, y + 20);       delay(100); {нормальная скорость, если модули *.TPL не глючные как у Вас,  время должно быть в миллисекундах, а не в каких-нибудь наносекундах}       x:=x-2;{шаг движения}     end;   end   else Writeln('Graphics error: ', GraphErrorMsg(ErrCode));  Settextstyle(0,0,3);{устанавливаем стиль шрифта}  cleardevice;  setcolor(red);  OuttextXY(200,240,'Rejs zavershen!');{выводим надпись}  readln;  CloseGraph; end.
annashersheva

1. 1987/7=283 остаток   6

283/7=40 остаток   3

40/7=5 остаток   5

5/7=0 остаток   5

1987(10)=5536(7)

1010101011(2)=1*2^9 +0*2^8 +1*2^7 +0*2^6 +1*2^5 +0*2^4 +1*2^3 +0*2^2 +1*2^1 +1*2^0 =683(10)

Переведём 1AE из системы счисления 16 в десятичную систему счисления :

1AE(16)=1*16^2 +10*16^1 +14*16^0 =430(10 )

430(10)=x(9)

430/9=47 остаток   7

47/9=5 остаток   2

5/9=0 остаток   5

430(10)=527(9 )

1AE(16) =527(9)

2. 11011110(2) * 110(2)=10100110100(2)

11011110(2)=222(10) 110(2)=6(10)

10100110100(2)=1332(10)

1101111(2) - 110111(2) = 111000(2)

1101111(2)=111(10) 110111(2)=55(10)

111000(2)=56(10)

1011110101(2) + 1110111(2) = 1101101100(2)

1011110101(2)=757(10) 1110111(2)=119(10)

1101101100(2)=876(10)

AnzhelikaSlabii1705

7

Объяснение:

I = t * f * i * k, где  

I - информационный объём аудио файла (размер файла, содержащего запись звука)

t - общая длительность звучания (секунды)

f - частота дискретизации (Гц, количество значений амплитуды звука, фиксируемых за одну секунду)

i - глубина звука (разрешение) (число бит, используемых для хранения каждого измеренного значения)

k -  количество каналов записи (1 - моно, 2 - стерео и т.д.)

1 байт = 8 бит

1 Кбайт = 1 024 байт

1 Мбайт = 1 024 Кбайт

1 мин = 60 сек

Дано:

k = 2

f = 64 кГц = 64 000 Гц

i = 24 бит = 3 байта

I = 144 Мбайт = 150 994 944 байт

Найти:

t

I = t * f * i * k

t = I / (f * i * k)

t = 150 994 944 / (64 000 * 3 * 2) = 150 994 944 / 384 000 = 393,216 сек = 6,5536 мин ≈ 7 мин

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу в паскале которая имитирует движения дельфина или кораблика по волнам. или что-то в этом роде.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

pucha5261
ksvish2012
Иванов
olimov9
saytru5850
elena
av52nazarov
mariavayda88734
спец Михасов
mereninka7008
kit036
Ольга1915
Vasilii1891
stendpost
leonidbaryshev19623