Васильевна Владимирович
?>

Написать программу на си ! : дана квадратная матрица. найти сумму четных элементов над побочной диагональю.

Информатика

Ответы

verachus

что-то типа этого:

const n = 8, m = 8;
var 
    A: array[1..n,1..m] of integer;
    i, j, sum, product: integer;
    isnotnull: boolean;
begin
    randomize;
    writeln('Случайная матрица:');    for i:=1 to n do begin
        for j:=1 to m do begin
            A[i,j] := random(51) - 25;
            write(A[i,j]:5);
        end;
        writeln;
    end;    sum := 0;
    for i:=1 to n do
        if A[i,n-i+1] < 0 then
            sum := sum + A[i,n-i+1];
    writeln('Сумма отрицательных элементов побочной диагонали = ', sum);    product := 1;
    isnotnull := False;
    for i:=1 to n-1 do
        for j:=2 to n do
            if (j > i) and (A[i,j] <> 0) then begin
                isnotnull := True;
                product := product * A[i,j];
            end;
    if isnotnull
        writeln('Произведение ненулевых элементов в области выше главной диагонали = ', product)
    else
        writeln('Ненулевых элементов в области выше главной диагонали нет.', product);    readln;
end.

zsv073625

Маска - один из самых полезных инструментов, если вы хотите управлять точностью нанесения и структурой текстуры. Также это позволяет наносить на один и тот же объект новые текстуры но с использованием одного материала.

Reminder on how to use texturing (напоминание того как использовать текстуру):

Запустите блендер и нажмите Ctrl X для того чтобы вернутся к стандартному виду сцены. Выберите куб и перейдите в меню материалов (F5). Если у вас уже есть созданный материал, удалите его и создайте новый.

Теперь перейдите в настройки текстуры (F6) выберете свободный слот текстуры и нажмите Add New для её создания.

Сейчас вы должны выбрать нужную вам текстуру. Если это картинка, то выберите из списка текстур Image. Затем загрузите нужную вам картинку. Теперь вернитесь в работу с материалом (F5) и найдите панель, которая находится в крайнем правом углу. Первая вкладка у этой панели это Texture. Здесь вы можете увидеть кол-во текстур наложенных на объект и выбрать их. Сейчас выбрана одна из них. Для выбора другой щелкните на названии нужной текстуры в этом списке.

Вторая вкладка это Map Input. Этот инструмент является более тонким. Он позволяет вам выбрать метод проектирования текстуры: Плоскость, Куб, Сфера, Труба. Также можно изменить текстурное наложения и величину текстуры по всем трем осям.

Объяснение:

semenov-1970
Программа распознаёт только целые числа.

Var
   f:file of char;
   C:char;
   k,s:integer;
Begin
Assign(f,'file.txt');
Reset(f);
k:=0;
s:=1;
Write('Найденные числа:');
Repeat
Read(f,C);
if ('0'<=C)and(C<='9') then
   Begin
   k:=k+1;
   Write(' ');
   While ('0'<=C)and(C<='9')and Not Eof(f) do
      Begin
      Write(C);
      Read(f,C);
      if C=#13 then s:=s+1;
      End;
   End;
Until Eof(f);
Close(f);
WriteLn;
WriteLn('Их количество: ',k);
WriteLn('Количество строк в файле: ',s);
End.

Результат работы программы:

Найденные числа: 1 2 3 7 8 9 11 12 3 2 1 8 1 2 3 4
Их количество: 16
Количество строк в файле: 5

Чтобы программа работала данный файл должен находиться в одной папке с программой:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на си ! : дана квадратная матрица. найти сумму четных элементов над побочной диагональю.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Элизбарян
Исаченко Тераски1181
dkvsadovoe
docvet4
соловьев_Куркина
uglichdeti
kareeva
dailyan539
ViktorovnaLarin
ipaskarovanv6
prohorovalena
tarja4140
Захаров-Иванович
danielianruz
fruktovahere