Банова_Елена431
?>

Напишите программу, которая выводит на экран все простые числа в диапазоне от 1 до числа, введенного с клавиатуры.

Информатика

Ответы

lanac3po
Var
i, j, n : integer;
flag : boolean;
begin
write('n = ');
read(n);
for i := 2 to n do begin
flag := true;
for j := 2 to i-1 do
if (i mod j = 0) then begin
flag:=false;
break;
end;
if flag = true then write(i, ' ');
end;
notka19746
Что такое Интернет и зачем он нужен?

Интернет и его функции

 Интернет – это всемирная компьютерная сеть. Она образует в результате соединения тысяч локальных компьютерных сетей (университетских, региональных и т. д. ), а так же компьютеров, подключённых к сети с отдельных каналов связи.

 Интернет – это огромное информационное пространство. Благодаря объединению ресурсов миллионов компьютеров, размещённых в различных уголках земного шара, сеть Интернет даёт возможность каждому её пользователю получить доступ к необъятным информационным богатством, позволяющим узнавать самые разнообразные сведения – начиная от прогноза погоды в вашем населённом пункте в конкретное время суток и заканчивая серьёзными аналитическими статьями на самые злободневные темы. Кроме чисто информационной функции, сеть Интернет также предоставляет модем множество дополнительных возможностей, позволяющих общаться посредством текстовой, голосовой и даже видеосвязи, загружать на свой компьютер музыку и видеоролики в популярных цифровых форматах (MPEG - 4, MP3), а также многое - многое другое. Бессмысленно пытаться перечислить здесь всё, что может предоставить Интернет своим посетителям, потому что даже пользователи с многолетним стажем обязательно забудут о какой - то важной и интересной возможности – на столько гигантскими по своему количеству и уникальными по своему разнообразию являются доступные в этой сети функции.

 Применение: Синонимами термина «Интернет» являются также слова и словосочетания, как «Глобальная сеть», «Всемирная сеть», «Сеть».
dima-pashkovec
#include <iostream>
#include <cstring>
#include <vector>
#include <algorithm>

struct StudentData
{
    std::string name;
    std::string surname;
    int math;
    int phys;
    int comp_science;
};

bool
comp(const StudentData &a, const StudentData &b)
{
    int tmp1 = a.math + a.phys + a.comp_science;
    int tmp2 = b.math + b.phys + b.comp_science;
    return tmp1 > tmp2 ? true : false;
}

int
main(void)
{
    int n;
    std::cin >> n;
    std::vector< StudentData > data(n);
    for (int i = 0; i < n; i++) {
        std::cin >> data[i].name >> data[i].surname;
        std::cin >> data[i].math >> data[i].phys >> data[i].comp_science;
    }
    std::sort(data.begin(), data.end(), comp);
    for (int i = 0; i < n; i++) {
        std::cout << data[i].name << " " << data[i].surname << std::endl;
    }
    return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая выводит на экран все простые числа в диапазоне от 1 до числа, введенного с клавиатуры.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

raa-0485428
bezzfamilny631
fursov-da
smalltalkcoffee5
PetrovDrozdov1785
yuda12
Lorvi_Shevkunova849
delta88
ivanrancev
kettikis
Vasilevich Fokin
borvalmok432
gurman171
polina3mag
Yurevich1344