kun1969
?>

Написать программу дано 4х значное число вывести на экран монитора первую и третью цифры, произведениэ этих цифр

Информатика

Ответы

monolit-kolomna
Div - целая часть деления. Например 2334 div 1000 = 2. 2334 div 100 = 23. Дальше сам
sveta300856729
Растровая графика описывает изображения с использованием цветных точек — пикселей, расположенных на сетке. Например, серфер в море описывается конкретным расположением и цветом каждой точки изображения, примерно, как в мозаике (фотографии, отсканированные рисунки и т.д.). При редактировании растровой графики изменяются пиксели, а не линии. Растровая графика зависит от разрешения, так как информация, описывающая изображение, прикреплена к сетке определенного размера. При изменении размеров данных файлов, качество может измениться, например, приведет к «разлохмачиванию» краев изображения, поскольку пиксели будут перераспределяться. Вывод растровой графики на устройства с более низким разрешением, чем само изображение, понизит его качество.
Применение растровой графики позволяет добиться качественного изображения, фотографического. Но все это создается за счет большого объема файла и работы вручную, т.е. при редактировании приходится поправлять каждую точку. Даже если использовать инструменты типа линии или примитивов (овалов, квадратов), то результат представляет собой изменение пикселей.

При изменении размеров изображений растровой графики качество ухудшается: при уменьшении — исчезают мелкие детали, а при увеличении картинка может превратиться в набор неряшливых квадратов (увеличенных пикселей).

При печати растровой графики или при просмотре на средствах, имеющих недостаточную разрешающую значительно ухудшается восприятие образа.
Разнообразие форматов растровой графики

Ни одна область применения компьютера не может похвастаться таким многообразием типов форматов файлов, как графика. Многие фирмы, выпуская графическую программу, создают свой собственных формат файлов, в котором редактор должен идеально сохранять все работы, созданные с его С увеличением количества существующих графических форматов совмещать их становится все труднее. Поэтому появилось несколько определенных форматов, ставших стандартами. Так, например, для изображений в Интернете в большинстве случаев используются форматы JPG и GIF, а в издательском деле царствует TIFF.
Многие растровые форматы обладают нести дополнительную информацию: различные цветовые модели изображения, вектора, альфа-каналы (дополнительный канал, с которого можно сохранять выделенные или прозрачные области изображения), слои различных типов, интерлиньяж (возможность чересстрочного показа изображения), анимацию, возможности сжатия и многое другое.

Достоинства растровых изображений передать тончайшие нюансы изображения, возможность редактировать индивидуально каждый пиксель, изменяя его параметры. Ну, а принципиальный недостаток один — очень большие размеры полученного файла.
tigran87-87
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

№1

begin
  var (a,k):=ReadInteger2('Укажите количество рабочих и служащих:');
  Writeln('Заработок работника равен ',624750/(a+k))
end.

Пример
Укажите количество рабочих и служащих: 15 6
Заработок работника равен 29750

№2

begin
  var y:=ReadReal('Укажите скорость ходьбы, км/ч:');
  var x:=ReadReal('Мальчик пробежал, км: ');
  Writeln('Затрачено времени на бег, ч: ',x/(3*y):0:2)
end.

Пример
Укажите скорость ходьбы, км/ч: 5.2
Мальчик пробежал, км:  12
Затрачено времени на бег, ч: 0.77

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу дано 4х значное число вывести на экран монитора первую и третью цифры, произведениэ этих цифр
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Zibuxin3
Dmitriy793
sapelnikovk-74
Марюк-Мубариз
zybin41iz81
Artyukhin545
lihacheva
mihalevskayat
nadnuriewa8110
rikki07834591
Марина566
elenasnikitina84
Anastasiamoscow80
av52nazarov
Элизбарян