hadzievamareta44
?>

Задание №1 Какое число будет выведено на экран после выполнения этого фрагмента программы? write(1); for i:=3 to 5 do write(i); Задание №2 Какое число будет выведено на экран после выполнения этого фрагмента программы? write(4); for i:=3 downto 1 do write(2*i); Задание №3 Чему будет равно значение целой переменной a после выполнения этого фрагмента программы? a:=10; for i:=1 to 2 do begin a:=a-2; end; Задание №4 Определите, что будет напечатано в результате работы следующей программы. Var k, і: integer; Begin k:= 4; For і:= 1 to 3 do k:= 2*k + і; Writeln(k); End.

Информатика

Ответы

elenaftdv7

1) i в цикле меняется от 2 до 1 с шагом -1, поэтому будет выведено:

2 1

2) Сначала выводится число 4, а затем i меняется в цикле от 4 до 2 с шагом -1, поэтому будет выведено:

4 8 6 4

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задание №1 Какое число будет выведено на экран после выполнения этого фрагмента программы? write(1); for i:=3 to 5 do write(i); Задание №2 Какое число будет выведено на экран после выполнения этого фрагмента программы? write(4); for i:=3 downto 1 do write(2*i); Задание №3 Чему будет равно значение целой переменной a после выполнения этого фрагмента программы? a:=10; for i:=1 to 2 do begin a:=a-2; end; Задание №4 Определите, что будет напечатано в результате работы следующей программы. Var k, і: integer; Begin k:= 4; For і:= 1 to 3 do k:= 2*k + і; Writeln(k); End.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sveta740450
moidela87
zrv85
xsmall1
гайсанов
Espivak
master-lamaster
Рожнов
Aleksandr740
Vika-simonenko
хуйдрочил_Анастасия
ilyagenius
Irinagarmonshikova
shakmeev
coffee2201
▲