sv455umarketing74
?>

Вклассе 20 учеников писали диктант по языку. напишите программу и начертите к ней блок-схему, подсчитывающую количество двоек, троек, четверок и пятерок за диктант. просто , 99 за программу и блок-схему.

Информатика

Ответы

ramco1972
Блок-схема - в прилагаемом файле. Программа:
const n=20;
var a:array[1..20] of integer;
i,k2,k3,k4,k5:integer;
begin
Randomize;
writeln('Оценки:');
for i:=1 to n do begin
 a[i]:=random(4)+2;
 write(a[i],' ');
 end;
writeln;
k2:=0;k3:=0;k4:=0;k5:=0;
for i:=1 to n do
 case a[i] of
  2: k2:=k2+1;
  3: k3:=k3+1;
  4: k4:=k4+1;
  5: k5:=k5+1;
 end;
writeln('Двоек: ',k2);
writeln('Троек: ',k3);
writeln('Четверок: ',k4);
writeln('Пятёрок: ',k5);
end.

Пример:
Оценки:
3 5 3 2 5 3 2 5 3 4 4 5 2 3 3 4 4 2 2 5 
Двоек: 5
Троек: 6
Четверок: 4
Пятёрок: 5
Вклассе 20 учеников писали диктант по языку. напишите программу и начертите к ней блок-схему, подсчи
Sadikova Gavrikov
Ячейка B5 - это второй столбец, пятая строка.
в задании ваша формула $B$-D$4 записана неверно. должно быть, например $B$3-D$4.

при копировании формулы $B$3-D$4 в ячейку Е10
$B$3 останется тем значением, потому зафиксированы символом $ и строка и столбец ячейки.
в D$4 изменится только столбец D, он четвертый по счету, на два столбца больше чем B, значение строки останется 4.

Тогда при копировании формула будет: $B$3-G$4
$B$3-E$4  - зафиксировано
$3 - зафиксировано
$4 - зафиксировано
G - на 2 столбца больше E будет столбец G

--
надеюсь понятно объяснила)
n-896458
Program rtr1;Uses crt;var a,s,d,e:integer;    ss,dd,ee:string;beginclrscr;Writeln('Введите число от 100 до 399');readln(a);s:=a div 100;e:=a  mod 100 mod 10;d:=a div 10 mod 10;case s of1: ss:='сто';2: ss:='двести';3: ss:='триста';end;case d of2: dd:='двадцать';3: dd:='тридцать';4: dd:='сорок';5: dd:='пятьдесят';6: dd:='шестьдесят';7: dd:='семьдесят';8: dd:='восемьдесят';9: dd:='девяносто';end;case e of1: ee:='один';2: ee:='два';3: ee:='три';4: ee:='четыре';5: ee:='пять';6: ee:='шесть';7: ee:='семь';8: ee:='восемь';9: ee:='девять';end;if d=1 then begin   case e of   1: dd:='одинадцать';   2: dd:='двенадцать';   3: dd:='тринадцать';   4: dd:='четырнадцать';   5: dd:='пятнадцать';   6: dd:='шестнадцать';   7: dd:='семнадцать';   8: dd:='восемнадцать';   9: dd:='девятнадцать';   end;write(ss,' ',dd);end elsewrite(ss,' ',dd,' ',ee);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вклассе 20 учеников писали диктант по языку. напишите программу и начертите к ней блок-схему, подсчитывающую количество двоек, троек, четверок и пятерок за диктант. просто , 99 за программу и блок-схему.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sayfullinmr
irinanikulshina144
Захаров-Иванович
phmad7
sanyaborisov910067
gullieta
milanmilan8672
Егорова
Maria095096
Konstantinovna Ilyukhin1618
Yuliya_Viktoriya316
mbobo28311
Alekseevich1012
lpcck2212
yanermarina87