misterdre9991
?>

Кто разбирается написать программу в паскаль: найти наибольшее из 3 заданных чисел a, b и c

Информатика

Ответы

korneevaa
Простая программка для сравнения 3 чисел(min_max_1): program min_max; var a,b,c,min,max: integer; begin write('введите 3 числа для сравнения (через пробел) : '); read(a,b,c); min: =a; max: =a; if b> max then max: =b; if b< min then min: =b; if c> max then max: =c; if c< min then min: =c; writeln('максимальное число : ',max); writeln('минимальное число : ',min); readln; end.
Tomilova1686

1) Гироскопический датчик

предназначен для измерения угла вращения робота или скорости вращения. Сверху на корпусе датчика нанесены две стрелки, обозначающие плоскость, в которой работает датчик.

2) Основным назначением ультразвукового датчика является измерение расстояния до контролируемого объекта или регистрация появления объекта в зоне «поля зрения» датчика. ... Измерив время до прихода отраженного сигнала из фактора скорости звука интегрированный в сенсор контролер рассчитывает расстояние до объекта.

3) Датчик цвета позволяет определять цвет поверхности. По сути это два устройства в одном - трехцветный светодиод и датчик освещенности, которые можно использовать по отдельности

Nikishina
Сначала банальный код - рабочий, но уже на больших числах будет переполнение переменной факториала.
var n, i, fact, ans : integer;
begin
  read(n);
  fact := 1;
  for i := 2 to n do
    fact := fact * i;
  while (fact mod 10 = 0) do begin
    ans := ans + 1;
    fact := fact div 10;
  end;
  writeln(ans);
end.

Теперь более "умный" код, в нём использован тот факт, что простое число p входит в разложение факториала числа N = [N/p] + [N/p^2] + [N/p^3] + ..., где [x] - целая часть числа x.
var n, i, fact, c, pow, ans : integer;
{c - сколько раз входит в разложение числа n! цифра 5}
begin
  read(n);
  pow := 5;
  while (pow <= n) do begin
    c += n div pow;
    pow := pow * 5;
  end;
  writeln(c);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Кто разбирается написать программу в паскаль: найти наибольшее из 3 заданных чисел a, b и c
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

des-32463
Chistova-Dmitrii1162
АндреевичАндрей
Tanyamitia
rytikovabs
Rinatum1978
valerii_Georgievna915
Alyona744
mzia-mzia-60682
simonovaliubov5852
yahottabych201379
Drugov_Vladimirovna
Руслан Руденко1262
ea9824165833886
blackpoint2020273