lighturist
?>

Паскаль доделать вклад в банке составляет x рублей. ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. каждый год сумма вклада становится больше. определите, через сколько лет вклад составит не менее y рублей. входные данные программа получает на вход три натуральных числа: x, p, y. выходные данные программа должна вывести одно целое число. program u1; var x, p , s, n: integer; y: real; begin read(x); read(p); read(y); s: =0; s: = x +(x*p)div 100; n: = 1; while (s < y) do begin s : = s +((s*p)div 100); n: = n + 1; end; writeln (n); readln; end. здесь где-то есть недоработка.

Информатика

Ответы

NurlanAleksandrovich
Program u1;
var 
x, p ,y, s, n: integer;
begin
readln(x,p,y); 
s:=x;
n:= 0; 
while (s < y) do 
begin 
s := s+trunc((s*p)/100); 
n:= n+1; 
end; 
writeln(n);
end.

Пример:
100 10 500
18
seregina19706867

"Написать программу,которая вводит массив из N целых чисел и выводит на экран элементы с чётными индексами(индексация начинается с нуля). Протестировать программу на произвольных массивах размерностью 5 и 8 элементов."

 

Для программы с 8-ми элементным массивом нужно const int n = 5 изменить на const int n = 8

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

int main()
{
    const int n = 5;
    int a[n];

    cout << "Enter 5 numbers: ";

    for(int i = 0; i < n; i++)
    {
        cin >> a[i];
    }

    for(int i = 0; i < n; i++)
    {
        if(i % 2 == 0)
        {
            cout << a[i] << ' ';
        }
    }
    cout << endl;

   return 0;
}


Написать программу,которая вводит массив из n целых чисел и выводит на экран элементы с чётными номе
Суховодова599

1)

var a:array [1..100] of integer; объявляем массив

i,n:byte; объявляем вс переменную i и переменную  n  для хранения количества элементов

 

begin

write('Введите n = ');readln(n); вводим n

for i:=1 to n do begin от 1 до n  цикл 

write('a[',i,']=');

readln(a[i]); вводим элементы в массив

end;

write('Исходный массив: ');

for i:=1 to n do выводим наш массив полностью

write(a[i],' ');

writeln;

write('Результат: '); выводим результат, в данном случае все элементы стоящие на четных местах

for i:=1 to n do

if i mod 2 =0 then write(a[i],' '); проверка на четность, мод - это оператор деления по остатку, если индекс делится на 2 без остатка, то выводим элемент

end.

 

2)

var a:array [1..100] of integer;

i,n:byte; s:longint; s объявляем для хранения суммы элементов

 

begin

s:=0; обнуляем s

write('Введите n = ');readln(n);  тут тоже самое, что и в первой задаче

for i:=1 to n do begin

write('a[',i,']=');

readln(a[i]);

s:=s+a[i]; вот здесь мы складываем каждый элемент массива в переменную s

end;

write('Исходный массив: ');

for i:=1 to n do  вывод массива

write(a[i],' ');

writeln('Сумма всех элементов массива = ',s); вывод суммы

end.

 

Удачи=)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль доделать вклад в банке составляет x рублей. ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. каждый год сумма вклада становится больше. определите, через сколько лет вклад составит не менее y рублей. входные данные программа получает на вход три натуральных числа: x, p, y. выходные данные программа должна вывести одно целое число. program u1; var x, p , s, n: integer; y: real; begin read(x); read(p); read(y); s: =0; s: = x +(x*p)div 100; n: = 1; while (s < y) do begin s : = s +((s*p)div 100); n: = n + 1; end; writeln (n); readln; end. здесь где-то есть недоработка.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Zeegofer
opel81
gorovoy-dv4088
mila-vsv
lakeeva90
moto-eskort
Vladimirovna-Ignatenko1890
Поліном 2x^4+x^3-7x^2+8x=0
lulu777
almihanika435
bellaalya13862
terma-msk1
Троцкая-Ивановна
leobashkurov1089
Taurus59707
morsh9345
▲