Косарев
?>

Вкниге на одной странице помещается k строк. таким образом, на 1-й странице печатаются строки с 1-й по k-ю, на второй — с (k+1)-й по (2∙k)-ю и т.д. напишите программу, которая по номеру строки в тексте определяет номер страницы, на которой будет напечатана эта строка, и порядковый номер этой строки на странице.

Информатика

Ответы

Васильевий
Пусть нужно узнать, где будет напечатана строка с номером n. Для предыдущих (n - 1) строк нужно (n - 1) div k полных страниц и ещё (n - 1) mod k строк на ((n - 1) div k + 1)-ой странице. n-я строка будет следующей на этой странице.

var
  n, k, fullPages, restLines: integer;
 
begin
  write('Номер строки: ');
  readln(n);
  write('Строк на странице: ');
  readln(k);
  fullPages := (n - 1) div k;
  restLines := (n - 1) mod k;
  writeln('Страница: ', fullPages + 1, ', строка: ', restLines + 1);
end.
 
superniki87

Відповідь:

import math

a = float(input(" Перша сторона трикутника = "))

b = float(input(" Друга сторона трикутника = "))

c = float(input(" Третя сторона трикутника = "))

d = [a, b, c]

e = (sum(d)-(min(d)+max(d)))   #знайдемо сторону,що має середнє значення у списку d

if a and b and c  > 0:

   if max(d) == math.sqrt(min(d)**2 + e**2) :

       print("Трикутник - прямокутникй")

   else:

       print("Трикутник не є прямокутним")

else:  

   print("Сторона трикутника не може мати від'ємних значень або дорівнювати нулю")

Пояснення:

На малюнку доказ,що програма правильно працює


До ть, будь ласкаPython З клавіатури вводяться довжини сторін трикутника. Визначити, чи є він прямок
Хромов1501

Відповідь:

import math

a = float(input(" Перша сторона трикутника = "))

b = float(input(" Друга сторона трикутника = "))

c = float(input(" Третя сторона трикутника = "))

d = [a, b, c]

e = (sum(d)-(min(d)+max(d)))   #знайдемо сторону,що має середнє значення у списку d

if a and b and c  > 0:

   if max(d) == math.sqrt(min(d)**2 + e**2) :

       print("Трикутник - прямокутникй")

   else:

       print("Трикутник не є прямокутним")

else:  

   print("Сторона трикутника не може мати від'ємних значень або дорівнювати нулю")

Пояснення:

На малюнку доказ,що програма правильно працює


До ть, будь ласкаPython З клавіатури вводяться довжини сторін трикутника. Визначити, чи є він прямок

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вкниге на одной странице помещается k строк. таким образом, на 1-й странице печатаются строки с 1-й по k-ю, на второй — с (k+1)-й по (2∙k)-ю и т.д. напишите программу, которая по номеру строки в тексте определяет номер страницы, на которой будет напечатана эта строка, и порядковый номер этой строки на странице.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Ka2ffka141
dmitrymakarov003
elmira01048775
Кедрин Карлен
nkaminskaja
Сергеевич
elenalukanova
martinzdraste
iraimironova
margusha1974
masha812
banketvoshod
jaksonj326
opal19575
Сергей_Крутикова114
▲