anazarov80
?>

Напишите программу в c++! дано предложение. вывести на экран слова, начинающиеся и оканчивающиеся на одну и ту же букву.

Информатика

Ответы

Елена Ирина
#include <iostream>
#include <string>

using namespace std;

#define IN 1 //внутри слова
#define OUT 0 //вне слова

int main()
{
    string s;
    getline(cin, s);
    int state = OUT; //позиция
    s = ' ' + s + ' ';
    int k = 0; //позиция начала слова
    for (int i = 0; i < s.size(); i++)
        if (s[i] == ' ') {
            if (state == IN && s[k] == s[i - 1])
                cout << s.substr(k, i - k + 1) << endl;
            state = OUT;
        } else if (state == OUT) {
            k = i;
            state = IN;
        }
    return 0;
}
maroseyka

1. Что такое файл?

Файл-это определенное количество информации (программа или данные), имеющее имя и хранящееся в долговременной (внешней) памяти.

2. Произнесите ключевые слова темы на трех языках.

Файл-Файл-File

Текстовый файл- Мәтіндәк файл-Text file

Двоичный файл- Екілдік файл-Binary file

3. Почему в программировании используют работу с файлами?

При вводе большого количества данных в программу, а также при выводе результата их обработки удобно использовать файловый ввод и вывод.

4. Какие виды файлов существуют в программировании?

В программировании существуют 2 типа файлов:

1. Текстовые файлы

2. Двоичные (бинарные) файлы

5. Перечислите этапы работы с файлами.

1 этап

Открытие файла

2 этап

Работа с файлами

3 этап

Закрытие файла

6. Какие виды режима открытия файла вам известны?

-`r` (read)- открытие на чтение (является значением по умолчанию)

-`w` (write)- открытие на запись. Содержимое файла удаляется, если файла не существует, создается новый.

-`a` (append)- открытие на дозапись: информация добавляется в конец файла.

7. В чем различие методов read() и readline)?

read()-прочитает весь файл сразу, а затем распечатает первые символы, занимающие столько байт, сколько указано в скобках. readline (), прочитает и распечатает только первые символы, занимающие столько байт, сколько указано в скобках.

8. Какой командой необходимо закрывать файл?

close( )

Егорова

Программа:

C:

№1)

#include <stdio.h>

int main()

{

   int x[10];

   int i;

   for (i = 0; i < 10; i++) x[i] = i;    // заполняем массив из 10 чисел от 0 до 9

   for (i = 0; i < 10; i++) printf("%d ", x[i]);

   

   int length = sizeof(x) / sizeof(int);  // кол-во элементов в массиве

   x[length - 1] *= 2;  // последний элемент умножаем на 2

   printf("\r\n");

   for (i = 0; i < 10; i++) printf("%d ", x[i]);

   

}

№2)

#include <stdio.h>

int main()

{

   int x[10];

   int i, count = 0;

   for (i = 0; i < 10; i++) x[i] = i;   // заполняем массив из 10 чисел от 0 до 9

   for (i = 0; i < 10; i++) printf("%d ", x[i]); // вывод массива

   

   for (i = 0; i < 10; i++)

       if (x[i] % 5 == 0) {

           count += 1;  // подсчёт количества

           x[i] = 55;  // замена на 55

       }

   

   printf("\r\n");

   for (i = 0; i < 10; i++) printf("%d ", x[i]); // вывод массива

   printf("\r\nЭлементов, кратных 5: %d\n", count);

}

№3)

#include <stdio.h>

int main()

{

   int x[10];

   int i, max = x[0];

   for (i = 0; i < 10; i++) x[i] = i;  // заполняем массив из 10 чисел от 0 до 9

   for (i = 0; i < 10; i++) printf("%d ", x[i]); // вывод массива

   

   for (i = 0; i < 10; i++)

       if (x[i] > max)

           max = x[i];

   

   printf("\r\nМаксимальный элемент: %d\n", max);

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу в c++! дано предложение. вывести на экран слова, начинающиеся и оканчивающиеся на одну и ту же букву.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

alina-bas
avdeevau807
Tatyanaaarzieva72
Dmitrii1763
БашуроваОльга369
Roman343247
abadaeva
Александр1991
novdodCT
ПогальниковАлёна589
anna241273
Marina658
AnnaChulyukanova3
goldenshtein33333
▲