ПогальниковАлёна589
?>

НА ПИТОНЕ С ИСПОЛЬЗОВАНИЕМ ДВУМЕРНОГО МАССИВА На шахматной доске (8×8) стоит одна белая шашка. Сколькими она может пройти в дамки? (Белая шашка ходит по диагонали. на одну клетку вверх-вправо или вверх-влево. Шашка проходит в дамки, если попадает на верхнюю горизонталь.) Входные данные Вводятся два числа от 1 до 8: номер номер столбца (считая слева) и строки (считая снизу), где изначально стоит шашка. Выходные данные Вывести одно число — количество путей в дамки. Примеры Ввод Вывод 3 7 2 1 8 1 3 6 4

Информатика

Ответы

Кулагина_Владимир1179

Алгоритм: положим в ячейку, где стоит шашка, значение 1. В некоторую ячейку с горизонталью i и вертикалью j можно добраться из клеток (i-1, j-1) и (i-1, j+1), если эти клетки существуют. Тогда для двумерного массива A, выступающего в роли доски, будет справедливо следующее утверждение: A[i+1][j] = A[i][j-1] + A[i][j+1]. Существовать ячейки не будут, если находятся в крайних столбцах: A[i+1][0] = A[i][1] и A[i+1][7] = A[i][6].

Программа:

y, x = map(int, input().split())

x, y = x - 1, y - 1

board = [[0]*8 for i in range(8)]

board[x][y] = 1

for i in range(x, 7):

   board[i+1][0] += board[i][1]

   for j in range(1, 7):

       board[i+1][j] += board[i][j-1] + board[i][j+1]

   board[i+1][7] += board[i][6]

print(sum(board[7]))

Марина_Мария

Прочитать четверостишие

Воспроизвести четверостишие в памяти

Рассказать четверостишие без единой ошибки

Объяснение:

Начало

Выполняется действие Прочитать четверостишие.

Затем, выполняется действие Воспроизвести четверостишие в памяти.

Затем, проверяется условие Рассказать четверостишие без единой ошибки.

Если условие верно (Руслан рассказал четверостишие без единой ошибки) цикл закончился. Если нет, то цикл идёт заново

(Выполняется действие Прочитать четверостишие.

Затем, выполняется действие Воспроизвести четверостишие в памяти.

Затем, проверяется условие Рассказать четверостишие без единой ошибки.

Если условие верно (Руслан рассказал четверостишие без единой ошибки) цикл закончился.)

Так будет по кругу, пока Руслан не расскажет четверостишие без единой ошибки.

Maksimova-Shorokhov303
Program sum_nechet;
var a: array [0..100] of integer;
var b,i,c,k:integer;
begin
    randomize;
    for i:=1 to 10 do
    begin
        a[i]:=random(10);
        writeln(a[i]); // Это можно не писать, просто чтобы видеть числа в массиве, если интересно.
    end;
    c := 0;
    b := 0;
    for i:=1 to 10 do
    begin
        if a[i] mod 2 = 0 then
        b := b + a[i]
        else
        c := c+ a[i];
    end;
    writeln('Нечетных ' , c);
    writeln('Четных ' , b);
    k:=0;
    for i:=1 to 10 do
    begin
        if a[i] = 0 then
        k:= k+1
    end;
    writeln('Нулей ' , k)
end.
       

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

НА ПИТОНЕ С ИСПОЛЬЗОВАНИЕМ ДВУМЕРНОГО МАССИВА На шахматной доске (8×8) стоит одна белая шашка. Сколькими она может пройти в дамки? (Белая шашка ходит по диагонали. на одну клетку вверх-вправо или вверх-влево. Шашка проходит в дамки, если попадает на верхнюю горизонталь.) Входные данные Вводятся два числа от 1 до 8: номер номер столбца (считая слева) и строки (считая снизу), где изначально стоит шашка. Выходные данные Вывести одно число — количество путей в дамки. Примеры Ввод Вывод 3 7 2 1 8 1 3 6 4
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

rusvicktor
evatautes
leeka152522
annino
gip5362
avdeevau807
Monstr13
museumuzl
rigina82
margo929
озерская_Мария1234
Ragim777hazarovich
inj-anastasia8
goldenshtein33333
▲