gumirovane2294
?>

Напишите программу, которая вводит возраст человека (целое число, не превышающее 120)и выводит этот возраст со словом «год», «года» или «лет». например, «21 год», «22 года», «25 лет» на языке python.

Информатика

Ответы

Popova-Erikhovich
A = int(input('возраст: '))
if ((a//10)%10!=1):  
   if ((a%10)==1): print(a,' год')
   else:
       if (((a%10)>1)&((a%10)<5)): print(a,' года')
if (((a%10)==0) | ((a%10)>4) | ((a//10)%10==1)): print(a,' лет') 

возраст: 31
31  год

возраст: 103
103  года

возраст: 15
15  лет
nikdenly
Правильно оформляет любые случаи, даже вне 120.

# -*- coding: utf-8 -*-

def get_word(n):
    no_third = n % 100
    if no_third in range(11, 15):
        return "лет"
    last = no_third % 10
    if last == 1:
        return "год"
    if last in range(2, 5):
        return "года"
    else:
        return "лет"

iage = int(input("Возраст: "))
iword = get_word(iage)
print("{age} {word}".format(age=iage, word=iword))
Городничий_Коновалова384
A  B  C    A&B    B&C      (A&B) V (B&C)      
0   0   0       0         0                   0                    
0   0   1       0         0                   0                          
0   1   0       0         0                   0                   
0   1   1       0         1                   1                          
1   0   0       0         0                   0                     
1   0   1       0         0                   0                       
1    1  0       1         0                   1                      
1    1  1       1         1                   1  
использовали таблицу сложения и умножения лог.переменных для трех высказываний При сложении 0 V 0=0      0 V 1=1 V 0 =1    1V1=1
При умножении 0 & 0 =0    0&1=1&0 =0    1&1=1    
maglevanyycpt
Циклы итерационного типа.. это while и repeat? Тогда отличаются тем, что цикл с параметром всегда выполняется конечное число раз, итерационные циклы могут повторяться бесконечно.

Принцип действия цикла FOR(цикла с параметром): при изменении некой переменной от начала до конца выполняется тело цикла. Всё очень просто!

При вызове процедуры с параметрами необходимо указать все необходимые параметры.

Вызов процедур и функций осуществляется путём простого указания их названия в тексте программы (при необходимости - с требуемыми параметрами)

Процедура просто выполняет определённые действия, функция тоже выполняет некоторые действия, плюс она ещё вычисляет и возвращает в программу некоторое значение.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая вводит возраст человека (целое число, не превышающее 120)и выводит этот возраст со словом «год», «года» или «лет». например, «21 год», «22 года», «25 лет» на языке python.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Dr-motoshop
Кузнецов
armynis8
Евгеньевна_Хусинов
tcmir
Грудинин604
Алина1564
slitex
olga0909196323
tvtanya80
Наталья286
pavlovm8316
мария Кузив1393
Yurevich1243
silviya
▲