windless-el
?>

Напишите программу, которая вводит два вещественных числа, a и b ( a < b ), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) . входные данные входная строка содержит два вещественных числа a и b , разделённых пробелом. гарантируется, что a < b . выходные данные нужно вывести в одной строке через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) с тремя знаками в дробной части.

Информатика

Ответы

minchevaelena23
Program helpglupshkolnikam;
uses crt;
var a, b: real; i: integer;
begin  
randomize;  
readln(a,b);  
for i:= 1 to 5 do    
write(' ',(Random()*(b-a)+a):0:3, ' ');
end.
Мария
Var
  a,r:real;
begin
  Write('Введите a и n: '); Read(a,r);
  if a=2*r then Writeln('Квадрат описан около окружности')
  else Writeln('Квадрат не описан около окружности')
end.



var
  n:char;
  cm:string;
begin
  Write('Введите натуральное двухзначное число: '); Readln(cm);
  Write('Введите цифру от 0 до 9: '); Readln(n);
  if pos('3',cm)>0 then Writeln('В числе есть цифра 3')
  else Writeln('В числе нет цифры 3');
  if (pos('6',cm)>0) or (pos('7',cm)>0) or (pos('9',cm)>0)
    then Writeln('В числе есть цифра 6,7 или 9')
    else Writeln('В числе нет цифры 6,7 или 9');
  if pos(n,cm)>0 then Writeln('В числе есть цифра ',n)
  else Writeln('В числе нет цифры ',n)
end.
АлександровнаВладлен243
#include "conio.h" #include "stdlib.h" #include "iomanip" #include "iostream" #include "ctime" const int n=5; using namespace std;   void zapolnatb (int A[n][n]) {     srand(time(0));     for (int i=0;i<n;i++)     {         for (int j=0;j<n;j++)             A[i][j]=rand()%100-50;     } }   void vivodmat (int A[n][n]) {     for (int i=0;i<n;i++)     {         for (int j=0;j<n;j++)             cout<<setw(3)<<A[i][j];         cout<<endl;     } }   void naxogdenue (int A[n][n]) //max element v stroke {     int max;     int stl=0;     for(int i=0;i<n;i++)     {         max=A[i][0];         for (int j=0;j<n;j++)             if (max>A[i][j])             {                 max=A[i][j];                 stl=j;             }         cout<<setw(4)<<max<<setw(4)<<stl<<endl;     } }   void naxogdenuee (int A[n][n]) //min element v stroke {     int min;     int stl=0;     for(int i=0;i<n;i++)     {         min=A[i][0];         for (int j=0;j<n;j++)             if (min<A[i][j])             {                 min=A[i][j];                 stl=j;             }         cout<<setw(5)<<min<<setw(5)<<stl<<endl;     } }   void naxogdenueee (int A[n][n]) //min element v stolbce {     int min;     int str=0;     for(int j=0;j<n;j++)     {         min=A[0][j];         for (int i=0;i<n;i++)             if (min>A[i][j])             {                 min=A[i][j];                 str=i;             }         cout<<setw(6)<<min<<setw(6)<<str<<endl;     } }   void naxogdenu (int A[n][n]) //max element v stolbce {     int min;     int str=0;     int stl=0;     for(int j=0;j<n;j++)     {         min=A[0][j];         for (int i=0;i<n;i++)             if (min<A[i][j])             {                 min=A[i][j];                 str=i;                 stl=j;             }         cout<<setw(7)<<min<<setw(7)<<str<<endl;     } }   int main () {     int (A[n][n]);     zapolnatb (A);     vivodmat (A);     naxogdenue (A);     naxogdenuee (A);     naxogdenueee (A);     naxogdenu (A);     system ("pause");     return 0; }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая вводит два вещественных числа, a и b ( a < b ), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) . входные данные входная строка содержит два вещественных числа a и b , разделённых пробелом. гарантируется, что a < b . выходные данные нужно вывести в одной строке через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) с тремя знаками в дробной части.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

aeykin
Александрович Владимирович
drozd228758
baeva-larisa8165
oalexandrova75
MariyaKhanbalaeva585
nikitavertiev98400
eidevyatkina
zrs-546
yugraspets
Назаров588
Ushakova Sakhno
kris5009646
Бочкарева Горохова1652
zverevahelen