gbelihina
?>

Напишите программу, которая находит в массиве максимальный повторяющийся элемент или выводит число -1, если ни один элемент не повторяется. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести максимальный повторяющийся элемент в массиве или число -1, если ни один элемент не повторяется.

Информатика

Ответы

Belik-elena20111
Var 
 a:array [1..10000] of integer;
 i,n,a_max,c;
begin
 read(n);
 a_max:=0;
 c:=0;
 for i:=1 to n do 
 begin
  a[i] := random(100); // автозаполнение массива 
  print(a[i]);
  if a[i]>a_max then a_max:=a[i]; // поиск максимального элемента
 end;
 writeln;
 for i:=1 to n do 
  if a[i]=a_max then inc(c); // поиск повторяющихся элементов
 if c>=2 then write(a_max)
 else write(-1);
end.
Nazaruk_Kodochigov
1.
var
  s: string;
  i, count: integer;
begin
  writeln('Vvedite stroky: ');
  readln(s);
  for i := 1 to length(s) - 2 do
    if copy(s, i, 3) = 'abc' then
      count := count + 1;
  writeln('Kol-vo: ', count);
end.
2.
var
  s1, s2: string;
  i, len1, len2: integer;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  len1 := length(s1);
  len2 := length(s2);
  if len1 > len2 then writeln('1 stroka dlinnee')
  else if len1 < len2 then writeln('2 stroka dlinnee')
  else writeln('dlini strok ravnie')
end.
3.
var
  s1, s2, s3: string;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  s3 := s1[1] + s1[2] + s2[1] + s2[2];
  writeln('Novaja stroka: ', s3);
end.
Mariya-Karaseva
В прямоугольном треугольнике должна выполняться теорема Пифагора. Найдем самую длинную строну и проверим, является ли квадрат ее длины суммой квадратов длин двух других сторон. Для того, чтобы избежать ошибок округления примем, что все длины - натуральные числа.

PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,c):=ReadReal3('Введите через пробел или Enter стороны:');
  if a>c then Swap(a,c);
  if b>c then Swap(b,c);
  if c*c=a*a+b*b then Writeln('Треугольник прямоугольный')
  else Writeln('Треугольник не прямоугольный')
end.

Пример
Введите через пробел или Enter стороны: 6 8 10
Треугольник прямоугольный

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая находит в массиве максимальный повторяющийся элемент или выводит число -1, если ни один элемент не повторяется. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести максимальный повторяющийся элемент в массиве или число -1, если ни один элемент не повторяется.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

priexali
tigran87-87
ПодлеснаяМакарова1883
zelreiki
Strelkov-Roman1263
ele922009226536
priexali
mg4954531175
pravovoimeridian
Viktorovich395
МАМОНОВА-андрей
Максим
miha23727
sokolowskayaa
Горина
▲