uksusoval617
?>

1)составьте программу сумму и разность целых чисел a и b.2)составьте программу нахождения первой цифры двухзначного числа а.3) составьте программу вычисление суммы двузначного числа а.4) составьте программу вычисления суммы цифр трехзначного числа а. это разные

Информатика

Ответы

laplena1982750
1)
var a,b:real;
begin
readln(a,b);
writeln('А-Б=',a-b);
writeln(А+Б=',a+b);
end.
2)
var a:string;
begin
readln(a);
write(copy(a,0,1);
end.
3)
var a,s1,s2:string;
begin
readln(a);
s1:=copy(a,0,1);
s2:=copy(a,1,1);
write('Сумма цифр числа',a,'=',s1+s2);
end.
4)
var a,s1,s2,s3:string;
begin
readln(a);
s1:=copy(a,0,1);
s2:=copy(a,1,1);
s3:=copy(a,2,1);
write('Сумма цифр числа',a,'=',s1+s2+s3);
end.
alexk13

Вычитание выполнено в шестеричной системе счисления.

Объяснение:

Мы видим в данном выражении цифры до 4. Из этого следует, что система счисления использует не менее 5 цифр. То есть, она как минимум - пятиричная. Будем подбирать по порядку системы счисления и вычислять их значения.

Пятиричная система счисления:

1. Переводим в десятичную систему счисления:

102 = 25 * 1 + 5 * 0 + 1 * 2 = 25 + 0 + 2 = 27

14 = 5 * 1 + 1 * 4 = 5 + 4 = 9

2. Вычисляем в десятичной системе счисления:

27 - 9 = 18

3. Переводим в пятиричную систему счисления:

18 = 33

Вывод: данная система счисления не подходит.

Шестеричная система счисления:

1. Переводим в десятичную систему счисления:

102 = 36 * 1 + 6 * 0 + 1 * 2 = 36 + 0 + 2 = 38

14 = 6 * 1 + 1 * 4 = 6 + 4 = 10

2. Вычисляем в десятичной системе счисления:

38 - 10 = 28

3. Переводим в шестеричную систему счисления:

28 = 44

Вывод: данная система счисления подходит.

УДАЧИ! ОБРАЩАЙТЕСЬ!
sev-94428
Клавиши клавиатуры, в зависимости от их назначения и расположения, можно поделить на группы: -Алфавитно-цифровые; -Функциональные; -Блок дополнительных клавиш (цифровая панель); -Клавиши управления курсором; -Служебные (клавиши управления). -Алфавитно-цифровые клавиши. Назначение: ввод букв, цифр, знаков препинания и других специальных знаков. В эту категорию также относится клавиша SPACE (ПРОБЕЛ). -Функциональные клавиши Сюда относят клавиши F1-F12. За данными клавишами нет постоянных закрепленных функций (исключением является только клавиша F1, которая используется для получения справки). Эти клавиши, как правило, программируются уже пользователем для каждой программы отдельно. -Блок дополнительных клавиш (цифровая панель) Повторяют действие цифровых и некоторых знаковых клавиш основной панели Даная панель может использоваться в двух режимах: * Ввода цифр; * Управления курсором. Переключения режимов осуществляется клавишей NUM LOCK -Клавиши управления курсором Курсор — экранный указатель, который показывает место ввода следующего символа (для текста) или текущую позицию (точку), к которой будет применяться действие мыши. Клавиши со стрелками служат для перемещения курсора на одну позицию по экрану монитора в соответствии с направлением. Клавиши PAGEUP и PAGEDOWN3 переводят курсор на одну страницу вверх и вниз соответственно, а клавиши HOME и END переводят курсор в начало и конец текущей строки. Клавиша INSERT переключает режима ввода данных: вставка и замена ( в режиме вставки новые знаки вводятся без замены существующих символов, а в режиме замены — заменяют). Клавиша DELETE удаляет знаки, которые находятся справа от текущего положения курсора, а клавиша BACKSPACE удаляет знаки, которые находятся слева от текущего положения курсора.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1)составьте программу сумму и разность целых чисел a и b.2)составьте программу нахождения первой цифры двухзначного числа а.3) составьте программу вычисление суммы двузначного числа а.4) составьте программу вычисления суммы цифр трехзначного числа а. это разные
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

yaelenatu
shchepinasm
yyyaga
aetolstih
anna241273
Alekseevna1811
Bordo
iv1as2
bd201188
annino
dpodstrel85
YuRII1236
test43
boldireve617
citioil15
▲