Ольга тимур
?>

Нужно решить на языке паскаль. изучаем string. 1.дана строка. написать программу, выводящую сумму порядковых номеров заданного символа. 2.дано предложение состоящее из заглавных букв. в предложении только одно слово в котором 3 буквы. вам нужно написать программу которая найдет это слово и выведет его в файл.

Информатика

Ответы

Руслан1360
//PascalABC.NET 3.2 сборка 1318

Var
  s:string;
  c:char;
  sum,i:integer;
begin
readln(s);
readln(c);
for i:=1 to length(s) do
if s[i]=c then sum+=i;
writeln(sum);
end.

Пример ввода:
konichiva
i
Пример вывода:
11

//2
Var
  f:text;
  s:string;
  i:integer;
begin
readln(s);
var ars:=s.Split;
i:=0;
while ars[i].Length<>3 do
inc(i);
assign(f,'output.txt');
rewrite(f);
write(f,ars[i]);
close(f);
end.
  
Пример ввода:
ARK DRIVE FINISH
Пример вывода в файл output.txt:
ARK
ashantik
1. а) Петя едет в автобусе, читает книгу и насвистывает.
    б) Петя насвистывает, когда едет в автобусе или читает книгу.
    в) Петя едет в автобусе и читает книгу или насвистывает.
    г) то же, что и а).
   д) Петя едет в автобусе или читает книгу и насвистывает.
2. а) Число 5-простое = 1.    б) Луна-спутник Венеры = 0. 
  в) Число 5-простое и Луна-спутник Венеры = 0.
г) Число 5-простое или Луна-спутник Венеры = 1.
д) Если число 5-простое, то Луна-спутник Венеры = 0.
е) Число 5-простое тогда и только тогда, когда Луна-спутник Венеры = 0.
3. а) 1999<2000 и 1999>2000
б) Петя решил все задания контрольной работы и Петя не решил все задания контрольной работы
в) Неверно, что луна спутник Земли и Неверно, что луна не является спутником Земли
г) Мишень поражена не первым выстрелом и Неверно, что мишень поражена не первым выстрелом.
4. А=1,  В=0,  С=1,  Д=0.
besson89

// Массив из "a" заполнил псевдорандомными числами от 0 до 3 для наглядности

using System;

namespace ConsoleApp1

{

   internal class Program

   {

       private static void Main()

       {

           const int numsCount = 24;

           const int resCount = 10;

           double[] nums = new double[numsCount];

           double[] res = new double[resCount];

           var rand = new Random();

           for (int i = 0; i < numsCount; i++)

           {

               nums[i] = rand.Next(0, 4);

               Console.WriteLine($"a[{i}] = {nums[i]}");

           }

           Console.WriteLine();

           for (int i = 1; i <= resCount; i++)

           {

               double sum = 0;

               for (int j = 0; j < numsCount; j++)

                   sum += Math.Pow(nums[j], i);

               res[i - 1] = sum;

               Console.WriteLine($"b[{i - 1}] = {sum}");

           }

           Console.ReadLine();

       }

   }

}


Нужно написать программу в с# либо исправить мой код, который работает некорректно, Все как в услови
Нужно написать программу в с# либо исправить мой код, который работает некорректно, Все как в услови

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно решить на языке паскаль. изучаем string. 1.дана строка. написать программу, выводящую сумму порядковых номеров заданного символа. 2.дано предложение состоящее из заглавных букв. в предложении только одно слово в котором 3 буквы. вам нужно написать программу которая найдет это слово и выведет его в файл.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Dmitrii1763
Филиппович_Николаевич
Yuliya mikhail
Александрович Владимирович
TrofimovAnastasiya828
mdclcompany
озерская_Мария1234
Остап-Лаврова1410
tofilev
БашуроваОльга369
hbqhzwtd
Девяткина_Арсений
lor005148
ЕленаАнастасия315
andr77716
▲