Объяснение:
Відповідь:
Помилки та причини їх появи на етапах життєвого циклу
Помилка - це стан програми, при якому генеруються неправильні результати. Причиною помилок є недоліки в операторах програми або в технологічному процесі її розроблення, що призводить до неправильного перетворення вхідної інформації у вихідну. Дефект у програмі виникає внаслідок помилок розробника. Він може міститися у вхідних або проектних специфікаціях, текстах кодів програм, в експлуатаційній документації тощо. Відмова - це неможливість виконувати функції, визначені вимогами й обмеженнями. Вона виникає внаслідок таких причин:
o помилкової специфікації або пропущеної вимоги (специфікація точно не відображає припущення користувача);
o наявність вимоги, яку неможливо виконати на цій апаратурі і ПЗ;
o помилки у проекті програми (приміром, базу даних спроектовано без захисту від несанкціонованого доступу користувача, а захист потрібен);
o помилки в алгоритмі.
Помилки у ПЗ можна класифікувати відповідно до їхнього розподілу за етапами життєвого циклу і джерел їхнього виникнення:
1) ненавмисне відхилення розробників від робочих стандартів або планів реалізації;
2) специфікації функціональних та інтерфейсних вимог без дотримання стандартів розроблення;
3) недосконала організація процесу розроблення.
Помилки можуть виникати під час розроблення програмного забезпечення на різних етапах життєвого циклу. Розглянемо детальніше ці етапи.
1. Етап аналізу вимог. У визначенні вхідної концепції системи та опису вхідних вимог замовника виникають помилки аналітиків, коли вони формулюють специфікації верхнього рівня і будують концептуальну модель ПрО.
Характерні помилки:
o неадекватність опису специфікаціям вимог кінцевих користувачів;
o некоректність специфікації взаємодії програмного забезпечення із середовищем функціонування або з користувачами;
o невідповідність вимог замовника окремим і загальним властивостям програмного забезпечення;
o некоректність опису функціональних характеристик;
o незабезпеченість інструментальними засобами підтримки всіх аспектів реалізації вимог замовника тощо.
2. Етап проектування компонент. Помилки під час проектування компонент можуть виникати при описі алгоритмів, логіки управління, структур даних, інтерфейсів, логіки моделювання потоків даних, форматів введення-виведення тощо. В основі цих помилок лежать дефекти специфікацій аналітиків та помилок проектувальників.
Помилки можуть виникати під час:
o визначення інтерфейсу користувача із середовищем;
o опису функцій (неадекватності формулювань у проекті мети та завдань окремих компонентів, що виявляються при перевірці проекту);
o визначення процесу опрацювання інформації або зв'язків між процесами (наслідок некоректного визначення взаємозв'язків компонентів та процесів);
o визначення даних і їх структур для окремих компонент та програмного забезпечення, що в цілому некоректно задані;
o опису алгоритмів модулів та їхньої логіки, що некоректно визначені в поданому проекті модуля;
o визначення умов виникнення можливих помилок у програмі;
o порушення прийнятих для проекту стандартів та технологій
Поделитесь своими знаниями, ответьте на вопрос:
Объясните смысл программы в паскаль, распишите по действиям что мы делаем в каждой строке, вот : напишите программу, определяющую, лежит ли точка а (ха, уа) на прямой y=kx+l, над ней или под ней program b1; var xa, ya, y, k, x, l: real; begin writeln ('введите координаты точки a > > '); readln (xa, ya); writeln ('введите координаты k и l'); readln (k, l); if ya = k*xa +l then begin writeln ('точка a лежит на прямой') end else if ya> k*xa+l then begin writeln ('точка a лежит над прямой') end else if ya begin writeln ('точка a лежит под прямой') end end.