?>
Имеется последовательность чисел 0, 5, 50, 55, 500, 505, 550, 555, 5000, 5005, 5050 и так далее (числа состоят только из 0 и 5, числа записаны в порядке возрастания написать программу, которая при вводе n-го числа выводит по порядку в этой последовательности число. например, при вводе числа 8, программа должна выводить 555. при вводе числа 5, программа должны выводить 500.
Ответы
i - номер текущего элемента ряда;
n - число кратное 5-ти;
m - для проверки числа, является ли оно элементом ряда
var
k,i: byte;
n, m: longint;
begin
readln(k);
n := 0;
i := 1;
while i < k do begin
n := n + 5;
m := n;
while m > 0 do begin
if (m mod 10 <> 5) and (m mod 10 <> 0) then
break;
m := m div 10;
end;
if m = 0 then i := i + 1;
end;
writeln(n);
end;