saa002
?>

Написать программу, которая определяет , что введено с клавиатуры( прописная или строчня буква , прописная или строчная буква , цифра или символ) написать программу , которая определяет , к какой четверти координатной плоскости принадлежит точка. координаты точки вводятся с клавиатуры .написать все эти 2 программы в pascal ) )

Информатика

Ответы

phmad7
//1
begin
var ch:=readchar ('Введите символ: ');
if ch in ['A'..'z', 'А'..'я'] then
begin
if upcase(ch)=ch then write ('Прописная ') else write ('Строчная ');
if ch in ['A'..'z'] then write ('английская ') else write ('русская ');
write ('буква');
end
else if ch in ['0'..'9'] then write ('Цифра') else write ('Символ');
end.

//2
begin
var x:=readreal ('Ведите координаты точки: ');
var y:=readreal;
if (x=0) and (y=0) then write ('Точка лежит на начале координат') else
if x=0 then writeln ('Точка лежит на оси ординат') else
if y=0 then writeln ('Точка лежит на оси абсцисс') else
if x>0 then
if y>0 then write (1) else write (4)
else if y>0 then write (2) else write (3);
end.
NIKOLAEVNA
Целая часть от деления    Остаток от деления
840 div 2 = 420                 840 mod 2 = 0
420 div 2 = 210                 420 mod 2 = 0
210 div 2 = 105                 210 mod 2 = 0
105 div 2 = 52                  105 mod 2 = 1
52 div 2 = 26                    52 mod 2 = 0
26 div 2 = 13                    26 mod 2 = 0
13 div 2 = 6                      13 mod 2 = 1
6 div 2 = 3                        6 mod 2 = 0
3 div 2 = 1                        3 mod 2 = 1
1 div 2 = 0                        1 mod 2 = 1
Остаток от деления записываем в обратном порядке. Получаем число в 2-ой системе счисления: 1101001000
840 = 1101001000
alexderru
1)
var a:array [1..4] of integer;
var x,i,i1: integer;
begin
writeln('Введите 4-х значное число');
read(x);
for i:=1 to 4 do begin
a[i]:=x mod 10;
if a[i] mod 3 = 0 then begin
i1:=i1+a[i];
end;
x:=x div 10;
end;
write(i1);
end.

2)
Немного не понял:
var a:array [1..4] of integer;
var i,n,y: integer;
begin
n:=1;
for i:=1 to 4 do begin
writeln('Введите ',n, ' число');
read(a[i]);
if a[i]<0 then y:=y+1;
n:=n+1;
end;
write('Отрицательных чисел: ',y);
end.

3)
var i,y,x: integer;
begin
writeln('Выберите действие: 1)y=x^3 + x; 2)y=(x+1)^2; 3)y=sqr(x+4)');
read(i);
if i=1 then begin
writeln('Введите x');
read(x);
write('y=',(x*x*x)+x);
end
else begin
if i=2 then begin
writeln('Введите x');
read(x);
write('y=',(x+1)*(x+1));
end
else begin
if i=3 then begin
writeln('Введите x');
read(x);
write('y=',sqrt(x+4));
end;
end;
end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая определяет , что введено с клавиатуры( прописная или строчня буква , прописная или строчная буква , цифра или символ) написать программу , которая определяет , к какой четверти координатной плоскости принадлежит точка. координаты точки вводятся с клавиатуры .написать все эти 2 программы в pascal ) )
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Panei
kv135549
zuelv
mpityk
fishka-sokol14
Анатолий
pechinin
Olga-Borisovna
premiumoft
a800000
Сергей
oxy03214428
agaloan8
Илья_Ветклиники1655
dkedrin74038
▲