okison2847
?>

Решить на языке python 3.! последовательность состоит из натуральных чисел и завершается числом 0. определите, сколько элементов этой последовательности больше предыдущего элемента. (решение должно быть с циклом while)

Информатика

Ответы

Shalito
# coding: utf-8

'''
Последовательность состоит
из натуральных чисел и завершается
числом 0. Определите, сколько
элементов этой последовательности
больше предыдущего элемента.

Python 3.X.
'''

prev = int(input()) # ввод первого элемента
count = 0 # изначально 0 элементов

while True:
    n = int(input()) # ввод числа
    if n == 0:
        break # выход, если 0
    if n > prev:
        count += 1
    prev = n # смещение числа

print(count, "эл.")
Ольга

условие – выражение логического типа.

Цикл может не выполняться ни разу, если значение логического выражения сразу же оказывается ложь.

Серия команд, находящихся между begin и end, выполняются до тех пор, пока условие истинно.

Для того чтобы цикл завершился, необходимо, чтобы последовательность инструкций между BEGIN и END изменяла значение переменных, входящих в условие.

Цикл с постусловием (иначе цикл до) имеет вид:

Объяснение:

условие – выражение логического типа.

Цикл может не выполняться ни разу, если значение логического выражения сразу же оказывается ложь.

Серия команд, находящихся между begin и end, выполняются до тех пор, пока условие истинно.

Для того чтобы цикл завершился, необходимо, чтобы последовательность инструкций между BEGIN и END изменяла значение переменных, входящих в условие.

Цикл с постусловием (иначе цикл до) имеет вид:

Igorevich1559
Ну тут ты не указал какой масив, одновымерный или двохвымерный
я напишу для двохвымерного масива
Type Tabl = array [1..5,1..5] of integer;const A: Tabl = ((10,5,6,9,5) , (9,7,12,6,10), (5,4,8,9,11), (10,9,4,2,6), (8,4,6,9,5));var i,j:integer;var Ar,P: real;beginAr:=1;P:=0;for i:=1 to 5 do beginfor j:=1 to 5 dowrite (A[i,j]:3);writeln;end;for i:=1 to 5 dofor j:=1 to 5 do beginP:=A[i,j]+A[i,j];Ar:=(Ar+P)/25;write (Ar:5:2);end;writeln;end.

P.S. в константу можешь писать любые числа, которые придумаешь
Почти получилось, только со среднем арифметическим проблема
и должно быть записано все в таком порядке, как на втором скрине

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить на языке python 3.! последовательность состоит из натуральных чисел и завершается числом 0. определите, сколько элементов этой последовательности больше предыдущего элемента. (решение должно быть с циклом while)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Natysya7777
anikamalish
Tkachenko1050
nailya-abdulova25
Marianna45
vsnimschikov391
Morozova-Starikov
Arutyunovich
secretary
best00
emilmishin1032
osechkinandrejj
nmakarchuk
nsoro937
борисовна Елена78