Присакарь520
?>

Решить , в долгу не останусь (решил бы сам, но теории на руках нет) вопрос №601329 (тип: c) дано четырехзначное число. написать программу, которая выводит на экран число, образованное при перестановке первой и второй, третьей и четвертой цифр заданного числа (никакие поясняющие записи в программе делать не нужно! библиотеку conio.h и команду getch() перед отправкой файла необходимо удалить! ) пример входных и выходных данных № теста входные данные выходные данные 1 4561 5416 ответ: прикрепите файл с программой в формате cpp, pas, cs, fs или java.

Информатика

Ответы

zmlavra
Program n1;
var a,d1,d2,d3,d4: longint;
begin
readln(a);
d1:=a div 1000;
d2:=(a mod 1000) div 100;
d3:=(a mod 100) div 10;
d4:=a mod 10 ;
writeln(d2,d1,d4,d3);
end.
obar1
// PascalABC.NET 3.2, сборка 1387 от 20.02.2017

begin
  var s:=ReadInteger.ToString;
  Writeln(s[2],s[1],s[4],s[3])
end.
gurina50
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
begin
  var a:=MatrixRandom(7,7,0,9);
  var k:=0;
  for var i:=0 to 6 do begin
    for var j:=0 to 6 do begin
      Write(a[i,j]:3);
      if a[i,j] in [1..5] then Inc(k)
      end;
    Writeln
    end;
  Writeln('Кол-во элементов на [1,5]: ',k)
end.

Тестовое решение:
  2  1  7  3  3  2  7
  9  2  9  2  0  5  5
  4  2  6  9  4  6  0
  1  0  3  5  4  5  9
  6  3  6  0  2  0  8
  0  8  4  3  2  1  8
  6  0  4  4  5  4  0
Кол-во элементов на [1,5]: 27

Вариант "совсем для школы"

const
  n=7;
var
  a:array[1..n,1..n] of integer;
  i,j,k:integer;
begin
  Randomize;
  k:=0;
  for i:=1 to n do begin
    for j:=1 to n do begin
      a[i,j]:=Random(10);
      Write(a[i,j]:3);
      if a[i,j] in [1..5] then Inc(k)
      end;
    Writeln
    end;
  Writeln('Кол-во элементов на [1,5]: ',k)
end.
sadkofamily61
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016

function gcd(a,b:integer):integer;
// Нахождение НОД
begin
  while b<>0 do
  begin
    a:=a mod b;
    var i:=b; b:=a; a:=i
  end;
  Result:=a
end;

procedure Shorter(var a,b:integer);
// "сокращатель" дроби
begin
  var k:=gcd(a,b);
  a:=a div k;
  b:=b div k
end;

begin
  var a,b:integer;
  Writeln('Введите числитель и знаменатель дроби: ');
  Read(a,b);
  Write(a,'/',b,'='); Shorter(a,b); Writeln(a,'/',b)
end.

Тестовое решение:
Введите числитель и знаменатель дроби:
25 15
25/15=5/3

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить , в долгу не останусь (решил бы сам, но теории на руках нет) вопрос №601329 (тип: c) дано четырехзначное число. написать программу, которая выводит на экран число, образованное при перестановке первой и второй, третьей и четвертой цифр заданного числа (никакие поясняющие записи в программе делать не нужно! библиотеку conio.h и команду getch() перед отправкой файла необходимо удалить! ) пример входных и выходных данных № теста входные данные выходные данные 1 4561 5416 ответ: прикрепите файл с программой в формате cpp, pas, cs, fs или java.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

buhtovarish
Yumashev
Lianchikavon
Бражинскене_Алексей
pelagia-kola2658
apetrov13
Надежда-Алексеевна82
maroseyka
vera-sherepa231
Olybetezina1973
dianakryukova00
schumacher8
suturinavaleriya51
Oksana373
Белов_Лукина1339