Сергей_Евгеньевич1255
?>

1.составить программу табуляции функции f(x) на отрезке [a; b] шагом h.параметры a, b и h вводит пользователь с клавиатуры. f(x) = x/cosx. 2.найти значение выражения, используя цикл с параметром.предусмотрен ввод с клавиатуры значений всех переменных. дано натуральное n вычислить значение выражения: y = ( 1 - 1/2) * ( 1 - 1/4) ·· (1-1/2n

Информатика

Ответы

ksenyabobrovich7214
Var
A,B,H:real;
Begin
Write('A = ');ReadLn(A);
Write('B = ');ReadLn(B);
Write('H = ');ReadLn(H);
Repeat
WriteLn(A/Cos(A));
A:=A+H;
Until A>B;
End.

Var
N:integer;
Y:real;
Begin
Y:=1;
Write('N = ');ReadLn(N);
For N:= 1 to N do
    Y:=Y*(1-1/(N*2));
Write('Y = ',Y);
End.
pedalplanet

var

 n, k, s, sa: integer;

 

begin

 k := 0;

 s := 0;

 sa := 0;

 writeln('Введите последовательность, окончание ввода - число 0');

 repeat

   read(n);

   if (n mod 4 = 0) and (n mod 10 = 2) then s := s + n;

   if (n <> 0) and (n < 100) then inc(k);

   sa := sa + n

 until n = 0;

 readln;

 writeln('Сумма чисел, кратных 4 и заканчивающихся на 2, равна ', s);

 writeln('Количество чисел, не больших 100, равно ', k);

 writeln('Сумма последовательности равна ', sa);

 readln

end.

Объяснение:

Кирилл_Гульницкий

program zz1;

var n,n1,n2,n3:integer; //задаем переменные

begin

write('введите заданное трехзначное число');

read(n); //вводим с клавиатуры заданное трехзначное число

n1:=n div 100; //находим первую цифру числа

n2:=(n mod 100) div 10; //находим вторую цифру числа

n3:=n mod 10; //находим третью цифру числа

if (n1 mod 2 = 0)and(n2 mod 2 = 0)and(n3 mod 2 = 0) //проверяем, если все цифры четные, то выводим один ответ, если нет, то другой

then write('все цифры числа четные ') else write('некоторые цифры числа не четные');

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1.составить программу табуляции функции f(x) на отрезке [a; b] шагом h.параметры a, b и h вводит пользователь с клавиатуры. f(x) = x/cosx. 2.найти значение выражения, используя цикл с параметром.предусмотрен ввод с клавиатуры значений всех переменных. дано натуральное n вычислить значение выражения: y = ( 1 - 1/2) * ( 1 - 1/4) ·· (1-1/2n
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

margusha1974
ser7286
Тариелович871
Ivanskvortsov25
potap-ver20065158
cheberyako2013
snezhanaklimenkova
петрАфанасьев
sochi-expert
alenaya69918
ietishkin
Середа-Сергеенков980
mileva84
st7307
shakovaea
▲