Подумайте чуть, ведь все просто. Есть массив, у него гдето есть середина, или точка симметрии. Она находится как (n div 2). Если массив четной длины, то он делится на 2 равные части, если нечетный - в середине остается один элемент, который ни с кем менять не надо. Сейчас смотрим элементы первой половины for i:=1 to n div 2 запоминаем их x:=a[i]; присваиваем им значения симметричных им элементов с конца a[i]:=a[n-i+1]; например при n=10 a[1]:=a[10-1+1]; А элементам в конце присваиваем значения запомненных первых элементов a[n-i+1]:=x; Все, поменяли.
Dmitrii836
15.09.2021
Подумайте чуть, ведь все просто. Есть массив, у него гдето есть середина, или точка симметрии. Она находится как (n div 2). Если массив четной длины, то он делится на 2 равные части, если нечетный - в середине остается один элемент, который ни с кем менять не надо. Сейчас смотрим элементы первой половины for i:=1 to n div 2 запоминаем их x:=a[i]; присваиваем им значения симметричных им элементов с конца a[i]:=a[n-i+1]; например при n=10 a[1]:=a[10-1+1]; А элементам в конце присваиваем значения запомненных первых элементов a[n-i+1]:=x; Все, поменяли.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу в паскале! 1)вычисление значения функции y=7x^2-3x+6, при любом значение x 2)x=12a^2+7a-16, при любом значение a
x,a:real;
Begin
WriteLn('y = 7x^2 -3x +6');
Write('x = ');
ReadLn(x);
WriteLn('y = ',7*x*x -3*x +6);
WriteLn;
WriteLn('x = 12a^2 +7a -16');
Write('a = ');
ReadLn(a);
Write('x = ',12*a*a +7*a *16)
End.