Макаров1887
?>

Нужно написать программу! . заданный текст содержит только буквы и цифры. определить, обладает ли он следующим свойством: текст является десятичной записью числа, кратного 9паскаль, делфи)

Информатика

Ответы

milo4ka26
Var str:string;
begin
read(str);
if val(str) mod 9 = 0 then write('является')
else write('не является');
end.
okunevo2010

1110001100(в двоичной системе)

Объяснение:

256+652=908

908:2=454(ост.0)

454:2=227(ост.0)

227:2=113(ост.1)

113:2=56(ост.1)

56:2=28(ост.0)

28:2=14(ост.0)

14:2=7(ост.0)

7:2=3(ост.1)

3:2=1(ост.1)

1110001100(в двоичной системе) =908(в десятичной)

Чтобы из десятичной системы число перевести в двоичную систему, то нам нужно будет делить число на 2,и так каждый раз, до тех пор, пока в ответе не будет 1

Далее собираем вот этот вот последний ответ 1,и все остатки(кстати, собираем мы это все снизу вверх), и получаем наше двоичное число

Удачи!

julichca68
Эм, ну, обычно для такого задания дают рисунок. Исходя из рисунка строиться путь, т.к есть разные варианты дороги, нельзя к каждому написать один алгоритм.

Но он будет в роде: "влево/вправо пока закрашено"
таким образом, робот будет идти в сторону, до тех пор, пока клетки будут закрашены.
Также, если будет пробел (закрашено, по середине пусто, закрашено) , то нужно написать следующий алгоритм : "Если незакрашено вправо/влево"
НО если там будет извилистая дорога, то потребуются еще действия.
Надеюсь, вы поняли. Удачи!

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно написать программу! . заданный текст содержит только буквы и цифры. определить, обладает ли он следующим свойством: текст является десятичной записью числа, кратного 9паскаль, делфи)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

alexey
Наталья286
tcmir
Dr-motoshop
kulagin777
webotryvclub21
Kochinev4
Azarenkoff
markitandl
rimmatrotskaia303
juli19657
мария Кузив1393
Олегович Паутова
edubenskaya
Кузнецов
▲