MariyaKhanbalaeva585
?>

Решить ! нужно написать программу c. хорошая таблица имеется прямоугольная целочисленная таблица размером n•m. «путём» в этой таблице назовём последовательность из n+m-1 клеток, которая начинается из клетки (1, 1), заканчивается клеткой (n, m) и любые две идущие подряд клетки в этой последовательности имеют общую сторону. назовём таблицу «хорошей», если сумма чисел в клетках каждого пути в этой таблице одна и та же. определить, является ли данная таблица «хорошей». входные данные во входном файле input.txt записаны не более 10 таблиц. запись каждой таблицы содержит в первой строке два числа — количество строк n и количество столбцов m (1 ≤ n, 1 ≤ m, n•m ≤ 30000 в следующих n строках содержатся по m чисел — значения элементов таблицы — целые числа от -32000 до 32000. последняя строка входного файла содержит значения 0 0. выходные данные в единственную строку выходного файла output.txt нужно вывести строку из символов y и n. длина строки равна количеству таблиц во входном файле. символ y обозначает что соответствующая таблица «хорошая», n - иначе.

Информатика

Ответы

Valentinovna
Я решала эту задачу ...с горем - по - полам .. простите :(..
в ней должны быть равны элементы стоящие в одной побочной диагонале. всего побочных диагоналей n+m-1. 
достаточно хранить первую строку и последний столбец,

var n, m, i, j, b : integer;
 a : array [1..30000] of integer;
  t : boolean; begin assign(input,'input.txt');
reset(input);
 assign(output,'output.txt');
rewrite(output);
  readln(n,m);
 while n+m>0 do
 begin
 t:=true;
  for j:=1 to m do
 read(a[j]);
 for i:=2 to n do begin
 for j:=1 to m-1 do begin
  read(b);
 t:=t and (b=a[i+j-1]) end;
 read(b);
 a[m+i-1]:=b end;
 if t then write('Y') else write('N');
 readln(n,m) end;
 close(output) ;
end.
thebest59
#include <iostream>
#include <stdlib.h>
using namespace std;

int main() {
const int n = 10;
int a[n];
int k=0;

srand(time(0));
for (int i = 0; i < n; i++) {
a[i]=-20 + (101.0 / RAND_MAX) * rand();
cout << a[i] << " ";
}
cout <<"\n";
cout << "Чётные числа:\n";

for (int i = 0; i < n; i++){
 if (a[i] % 2 == 0) {
  cout << a[i] << " ";
  k++;
 }
}
cout <<"\n";
if (k > n-k) cout << "Чётных больше"; 
else if (k < n-k) cout << "Нечётных больше"; 
else cout << "Чётных и нечётных поровну";
cout <<"\n";

return 0;
}

Пример:
27 11 77 59 28 8 59 64 16 80
Чётные числа:
28 8 64 16 80
Чётных и нечётных поровну
museumuzl
#include <cstdlib>
#include <ctime> 
#include <iostream>
using namespace std;

int main() {
    int n=10,k=0;
    int a[n];
    srand(time(NULL));
    cout<<"array:"<<endl;
    for (int i=0; i<n; i++)
    {
      a[i]=rand() % 50;
      cout<<a[i]<<" ";
    }
    cout<<endl;
    for (int i=0; i<n; i++)
    if (a[i]%2==0 && a[i]!=0)  {
       cout<<a[i]<<" ";
       k++;
    }
    cout<<endl;
    if (k>n-k) cout<<"четных больше";
    else if (k<n-k) cout<<"нечетных больше";
    else cout<<"равное количество";
    cout<<endl;
 
    system("pause");
    return(0);
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить ! нужно написать программу c. хорошая таблица имеется прямоугольная целочисленная таблица размером n•m. «путём» в этой таблице назовём последовательность из n+m-1 клеток, которая начинается из клетки (1, 1), заканчивается клеткой (n, m) и любые две идущие подряд клетки в этой последовательности имеют общую сторону. назовём таблицу «хорошей», если сумма чисел в клетках каждого пути в этой таблице одна и та же. определить, является ли данная таблица «хорошей». входные данные во входном файле input.txt записаны не более 10 таблиц. запись каждой таблицы содержит в первой строке два числа — количество строк n и количество столбцов m (1 ≤ n, 1 ≤ m, n•m ≤ 30000 в следующих n строках содержатся по m чисел — значения элементов таблицы — целые числа от -32000 до 32000. последняя строка входного файла содержит значения 0 0. выходные данные в единственную строку выходного файла output.txt нужно вывести строку из символов y и n. длина строки равна количеству таблиц во входном файле. символ y обозначает что соответствующая таблица «хорошая», n - иначе.
Ваше имя (никнейм)*
Email*
Комментарий*