aleksey7800
?>

Напишите программу, вычисляющую разность двух целых неотрицательных чисел. гарантируется, что первое число не меньше второго. входные данные даны два числа, второе из них не превышает первого. числа не превышают 10100 выходные данные выведите разность данных чисел. примеры входные данные 7 5 выходные данные 2

Информатика

Ответы

Ляпунов_Владмирович
Uses crt;
var a, b: Integer;
begin
readln(a, b);
clrscr;
writeln(a - b);
end.
Федорович Шахова241
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  WriteAllText('MyFile.txt',SeqRandom(n,-99,99).JoinIntoString);
  var (mn,mx):=(MaxInt,-MaxInt);
  foreach var line in ReadLines('MyFile.txt') do begin
    var a:=line.ToIntegers;
    (mn,mx):=(Min(a.Min,mn),Max(a.Max,mx))
    end;
  Writeln('Cумма min+max = ',mn,'+',mx,' = ',mn+mx);
  ReadAllText('MyFile.txt').Println // контрольный вывод файла
end.

Пример
n= 20
Cумма min+max = -99+71 = -28
62 -72 39 -93 -99 -46 -77 71 -12 13 -89 18 -17 19 -35 -62 30 17 -74 37
OlgaVasilevna
1. переговоры в интернете не требуют встречи лицом к лицу, поэтому это экономит на переезд в другой город(страну)
2.дистанционное обучение- самообучение не находясь в школе Минусы- большую часть программы ребенок может не понять ребенок
Плюсы- ребенок сможет пройти всю программу обучения не тратя деньги  и энергию на поход в школу пешком или на автобусе
Очное- ребенок учиться лицом к лицу с учителями и своими сверсниками
минусы- трата время и денег на путь в школу
плюсы- с объяснением учителей ребенок понимает большуу часть школьной программы

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, вычисляющую разность двух целых неотрицательных чисел. гарантируется, что первое число не меньше второго. входные данные даны два числа, второе из них не превышает первого. числа не превышают 10100 выходные данные выведите разность данных чисел. примеры входные данные 7 5 выходные данные 2
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Yuliya701
BelyaevNadezhda223
glebshramko
office
dmitrij-sp7
dubaiexport
andrewshilin1334
brand
lion13
Bogataya Vladimir318
Михеев557
voloshin238
tokarevmax
Давид-Ольга
argent