Boykoyelena
?>

Составить алгоритм сложения двух целых чисел b и n, вводимых с клавиатуры. результат сложения записать в виде переменной p. по данному алгоритму написать программу в паскале. алгоритм 1)алг сложение цел b, n, p нач ввод b ввод n p: =b+n вывод p кон 2)алг сложение цел b, n, p нач ввод b ввод n p=b+n вывод p кон 3)алг сложение цел b, n, p нач ввод b ввод p n: =b+p вывод p кон программа в паскале 1)program summa; var b, n, p: integer; begin readln(b); readln(n); p: =b+n; writeln(p); end. 2)program summa; var b, n, p: integer; begin readln(b); readln(n); p: =b+n; writeln(p); 3)program summa; var b, n, p: integer; begin readln(b); readln(n); p: =b+n; writeln(b); end.

Информатика

Ответы

grekova5
Составить алгоритм сложения двух целых чисел B и N, вводимых с клавиатуры. Результат сложения записать в виде переменной P. По данному алгоритму написать программу в Паскале.
Алгоритм
1)алг сложение
цел B,N,P
нач
ввод B
ввод N
P:=B+N
вывод P
кон

Программа в Паскале
1)program summa;
var
B,N,P:integer;
begin
readln(B);
readln(N);
P:=B+N;
writeln(P);
end.
konnovakat1
Задание 1

\ln(\frac{1}{\tan(x)}-1)=a\\\frac{1}{\tan(x)}-1 = \exp(a)\\\frac{1}{\tan(x)} = \exp(a) + 1\\\tan(x) = \frac{1}{\exp(a) + 1}\\x = \arctan(\frac{1}{\exp(a) + 1}) + \pi n, n \in Z

Для получения корня между \pi и 2\pi n = 1.

\\x = \arctan(\frac{1}{\exp(a) + 1}) + \pi

Задние 2

nh = A div C - количество квадратов умещающихся по-вертикали

nw = B div C - количество квадратов умещающихся по-горизонтали

n = nh * nw = общее количество квадратов.

Sr = A * B - 2*C*C

Код:

using System;namespace ThisAnswerIsNotMine {    class Program    {        private static void Eq(double a)        {            var x = Math.Atan(1 / (Math.Exp(a) + 1)) + Math.PI;            Console.WriteLine($"Для a = {a}, x = {x}");        }                private static void Squares(int A, int B, int C)        {            int nh = A / C;            int nw = B / C;            int n = nh * nw;            int Sr = A * B - 2*C*C;                        Console.WriteLine($"Количество квадратов со стороной {C} в прямоугольнике размером {A}x{B} равно: {n}");            Console.WriteLine($"Площадь оставшегося куска {Sr}");        }        private static void Main()        {            Eq(double.Parse(Console.ReadLine()!));            Squares(int.Parse(Console.ReadLine()!), int.Parse(Console.ReadLine()!), int.Parse(Console.ReadLine()!));        }    }}
может кто умеет писать на с# Программирование на языке с Для заданного а вычислить принадлежащий инт
makitra08

1.

program asd;
uses crt;
var
a: array[1..10] of integer;
i:integer;
sum:integer;
begin
writeln('Введите 10 цифр по очереди');
for i:=1 to 10 do
begin
readln(a[i]);
if (a[i]>7) then begin a[i]:=7; sum:=sum+1; end;
end;

writeln(' ',sum);

end.

 

2. смысл задания? 10/2=5 или индексами ты имела ввиду значениями? 

3.
program asd;
uses crt;
var
a: array[1..10] of integer;
i:integer;
naib:integer;
begin
writeln('Введите 10 цифр по очереди');
for i:=1 to 10 do
begin
readln(a[i]);
if (a[i]>naib) then naib:=a[i];
end;

writeln(' ',naib);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить алгоритм сложения двух целых чисел b и n, вводимых с клавиатуры. результат сложения записать в виде переменной p. по данному алгоритму написать программу в паскале. алгоритм 1)алг сложение цел b, n, p нач ввод b ввод n p: =b+n вывод p кон 2)алг сложение цел b, n, p нач ввод b ввод n p=b+n вывод p кон 3)алг сложение цел b, n, p нач ввод b ввод p n: =b+p вывод p кон программа в паскале 1)program summa; var b, n, p: integer; begin readln(b); readln(n); p: =b+n; writeln(p); end. 2)program summa; var b, n, p: integer; begin readln(b); readln(n); p: =b+n; writeln(p); 3)program summa; var b, n, p: integer; begin readln(b); readln(n); p: =b+n; writeln(b); end.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

maximovpavel9114
vitbond12
galkavik
elenachuxina804
makitra08
kukoleva
laleonaretouch
Roman913
lorsam36
marinatehnomaster21
annaar497
Tomilova1686
sv-opt0076
dianabuchkina
Николаевич1033
▲