tanyashevvvv
?>

Напишите программу на паскале. только полностью: дано натуральное n. вычислить: 2/1 + 3/2 + 4/3 ++n+1/n ( циклический алгоритм; цикл с заданным числом повторений

Информатика

Ответы

ser7286
Var n,i:integer; s:real;
begin
write('n = ');
readln(n);
s:=0;
for i:=1 to n do s:=s+(i+1)/i;
writeln('s = ',s:6:4);
end.

Пример:
n = 5
s = 7.2833
tatk00
Const
  MAX_SIZE = 10;
 
var
  a: array[1..MAX_SIZE] of integer;
  i, size: integer;
 
procedure delete_odd_elements();
var i, j: integer;
begin
  i := 1;
  repeat
    if odd(a[i]) then
    begin
      dec(size);
      for j := i to size do
        a[j] := a[j + 1]
    end
    else inc(i);
  until i > size;
end;
 
begin
  writeln('Исходный массив: ');
  size := MAX_SIZE;
  for i := 1 to size do
  begin
    a[i] := random(100);
    write(a[i] : 3);
  end;
  delete_odd_elements;
  writeln;
  writeln('Полученный массив: ');
  for i := 1 to size do
    write(a[i] : 3);
end.
Georgievna1407

Для начала, переведем код в десятичную систему счисления.

110100102 = 21010

110011002 = 20410

110011112 = 20710

110100112 = 21110

Получаем: 210 204 207 211

Зная, что буква «А» кодируется как 192, а код каждой последующей буквы на 1 больше кода предыдущей буквы. Определим код остальных букв и расшифруем наше слово.

А-192

Б-193

В-194

Г-195

Д-196

Е-197

Ё-198

Ж-199

З-200

И-201

Й-202

К-203

Л-204

М-205

Н-206

О-207

П-208

Р-209

С-210

Т-211

У-212

Ф-213

Х-214

Ц-215

Ч-216

Ш-217

Щ-218

Ъ-219

Ы-220

Ь-221

Э-222

Ю-223

Я-224

СЛОТ

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на паскале. только полностью: дано натуральное n. вычислить: 2/1 + 3/2 + 4/3 ++n+1/n ( циклический алгоритм; цикл с заданным числом повторений
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Федор_Рауф1592
shalashcoffee
autofilters27
mir5552
gamolml
evainvest1
Ерцкин_Овечкина391
amarantmetall
asyaurkova
Vasilii1891
AnvarzhonovichNadezhda1071
Yevgenii_Gurtovaya1532
Lyudmila-Popova
veronica1344
Andreeva
▲