apro3444595
?>

1.написать программу вывода чисел от a до b( a и b вводит пользователь) с шагом в 1. 2.вывести их произведение и сумму. программа с++. 50 .

Информатика

Ответы

lirene
1.
#include <iostream>
using namespace std;

int main()
{
    int a, b;
    cout << "a = ", cin >> a;
    cout << "b = ", cin >> b;
    for (int i=a; i<=b; i++) {
    cout << i << " ";
    }
    return 0;
}

Пример:
a = 5
b = 12
5 6 7 8 9 10 11 12

2.
#include <iostream>
using namespace std;

int main()
{
    int a, b, s=0;
    long long p=1;
    cout << "a = ", cin >> a;
    cout << "b = ", cin >> b;
    for (int i=a; i<=b; i++) {
    p = p*i;
    s = s+i;
    }
    cout << "p = " << p << " s = " << s;
    return 0;
}

Пример:
a = 5
b = 12
p = 19958400 s = 68
chetverikovalex3738
Программа, которая использует два массива

var 
c, a: array[1..20] of integer; 
i: integer;
begin 
write('Первый массив '); 
for i := 1 to 20 do   begin   
c[i] := i * (-5);   
write(c[i], ' '); 
end; 
writeln; 
write('Преобразованный массив '); 
for i := 1 to 20 do   begin   
a[i] := c[20 - i + 1];   
write(a[i], ' '); 
end;  
end.

ИЛИ  Программа не использующая два массива, а просто переворачивающая первый

var 
c: array[1..20] of integer; 
i: integer;
begin  write('Первый массив '); 
for i := 1 to 20 do   begin   
c[i] := i * (-5);   
write(c[i], ' '); 
end; 
writeln; 
write('Преобразованный массив '); 
for i := 20 downto 1 do  write(c[i], ' '); 
end.

Обе программы работают!
ANDREY261965
в кинозале всего 16×32=512 мест. Сообщение о купленном билете однозначно определяет выбор одного из этих мест. Из уравнения 2 i = 512=29получаем: i=9 бит. Но эту же задачу можно решать иначе. Сообщение о номере ряда несет 4 бита информации, т.к. 24=16. Сообщение о номере места несет 5 бит информации, т.к. 25=32. В целом сообщение про ряд и место несет: 4+5=9 бит информации. Данный пример иллюстрирует выполнение закона активности информации (правило сложения): количество информации в сообщении одновременно о нескольких результатах независимых друг от друга событий равно сумме количеств информации о каждом событии отдельно.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1.написать программу вывода чисел от a до b( a и b вводит пользователь) с шагом в 1. 2.вывести их произведение и сумму. программа с++. 50 .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Максим
dariamay1996
eutenkova805
puma802
ikalabuhova
sanseth5
mvolkov8
annasv8
Aleksandrova Zhanna1250
themolodoy
mbudilina
Dimston134877
Galliardt Sergeevna1284
Stepanovich_Makarov
ЕлизаветаВладимирович
▲