magnit-expo
?>

Написать программу-найти в массиве из 5 целых чисел номера отрицательных элементов(вывести их на экран), если таких нет, то сообщить об этом

Информатика

Ответы

Елена Васильева839
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(5,-20,20); a.Println;
  var s:=a.Select((x,i)->(x,i)).Where(k->k[0]<0);
  if s.Count>0 then s.Select(k->k[1]+1).Println
  else Writeln('Отрицательных элементов нет')
end.

Пример
-6 -16 20 7 -19
1 2 5
Yelena_Irina826
#include <iostream>
#include <cstdlib>
#include <ctime>

int main(int argc, char *argv[])
{
system("chcp 1251 >nul");
setlocale(LC_ALL, "Russian");
srand(time(NULL));

int mass[5];
bool op;

printf("Заполнить массив самостоятельно? (1/0): ");
scanf("%d", &op);
for(int i = 0; i < 5; i++){
if(op){
printf("Введите %d-е число: ", i+1),
scanf("%d", &mass[i]);
}else mass[i] = (rand() % 200) - 100;
}
std::cout << std::endl;
int sm = 0;
for(int i = 0; i < 5; i++)
if(mass[i] < 0) printf("%d-й элемент отрицательный: %d\n", i+1, mass[i]), sm++;
if(!sm) printf("В массиве нет отрицательных чисел.");

return EXIT_SUCCESS;
}
PetrovDrozdov1785

1) 23+16=39 символов было в сообщении первоначально

2) 23 × 1 байт = 23 байт общий объем первого сообщения без русского алфавита

3) 16 × 2 байта = 32 байт информационный объем сообщения русского алфавита до перекодировки

4) 23+32=55 байт - информационный объем сообщения до перекодировки

5) 39 × 2 байт = 78 байт информационный обем сообщения после перекодировки ( в Unicode 1 символ - 2 байта)

6) 4 Кбит ×1024/8 = 512 байт объем добавленного сообщения

7) 78+512 = 590 байт стал информационный объем сообщения после добавления еще одного сообщения

8) 590 - 55 = 535 байт увеличился итоговый информационный объем

 

ответ: 535 байт

alexandr25901

В алфавитах ориентироваться легко: смотрим сколько цифр используется такое будет и название

В алфавитах ориентироваться легко: смотрим сколько цифр используется такое будет и название0,1,2,3 - 4 цифры система счисления называется четверичная

В алфавитах ориентироваться легко: смотрим сколько цифр используется такое будет и название0,1,2,3 - 4 цифры система счисления называется четверичная0,1,2,3,4,5  - 6 цифр система счисления называется шестеричная

В алфавитах ориентироваться легко: смотрим сколько цифр используется такое будет и название0,1,2,3 - 4 цифры система счисления называется четверичная0,1,2,3,4,5  - 6 цифр система счисления называется шестеричная0,1,2,3,4,5,6,7,8  - 9 цифр система счисления называется девятеричная

В алфавитах ориентироваться легко: смотрим сколько цифр используется такое будет и название0,1,2,3 - 4 цифры система счисления называется четверичная0,1,2,3,4,5  - 6 цифр система счисления называется шестеричная0,1,2,3,4,5,6,7,8  - 9 цифр система счисления называется девятеричная0,1,2,3,4,5,6,7,8 ,9,А,В - 12 цифр система счисления называется двенадцатеричная (это если выписаны правильно все буквы и больше нет никаких. В случае, если есть ещё буквы C,D,E,F - СИСТЕМА СЧИСЛЕНИЯ БУДЕТ НАЗЫВАТЬСЯ ШЕСТНАДЦАТЕРИЧНАЯ

Если сделай эту ответ лучшим мне на следующий статус надо)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу-найти в массиве из 5 целых чисел номера отрицательных элементов(вывести их на экран), если таких нет, то сообщить об этом
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

LidiyaBorzikh
llmell6
Aleksandrovna370
Sharap
Инна_Nina1182
Виктория1690
podenkovaev314
len4ik1986
melnik-738
shoko91
yurkovam-037
vadimnechaev23150
Bi-1704
Зинина-Олесия
lyukiss
▲