Татьяна902
?>

На вход программе подаётся последовательность символов, заканчивающаяся точкой. требуется написать программу, которая определяет, есть ли в этой последовательности цифры, и выводит наибольшее число, которое можно составить из этих цифр. ведущих нулей быть не должно, за исключением одного нуля. если числа нет, выводится сообщение 'no', если число есть - 'да' и в следующей строке искомое число. например, если исходная последовательность была такая: day 10, mice 8: "year" 7 is a mistake 91. то результат должен быть следующий: да 987110

Информатика

Ответы

marysya60
Begin
  var s := readstring();
   if(s.Any(x -> x.isDigit)) then
   begin
  if(s.Any(x->x in['1'..'9'])) then
  s.Where(x -> x.IsDigit).OrderByDescending(x -> x).Println
  else
  write(0);
  end
  else
writeln('No');
 end.
ЧумичеваГеннадьевна1827
Var
   A:array['0'..'9'] of longint;
   C:char;
   i:integer;
Begin
For C:= '0' to '9' do A[C]:=0;
Repeat
Read(C);
if C in['0'..'9'] then A[C]:=A[C]+1;
Until C = '.';
if (A['1']=0)and(A['2']=0)and(A['3']=0)and(A['4']=0)and(A['5']=0)and(A['6']=0)and(A['7']=0)and(A['8']=0)and(A['9']=0) then
   if A['0']=0 then Write('no')
   else
      Begin
      WriteLn('Да');
      WriteLn(0);
      End
else
   Begin
   WriteLn('Да');
   For C:='9' downto '0' do
       For i:= 1 to A[C] do
           Write(C)
   End
End.
andreyshulgin835

ответ:Цикл for

Если мы знаем точное количество действий (итераций) цикла, то можем использовать цикл for. Синтаксис его выглядит примерно так:

for (действие до начала цикла;

условие продолжения цикла;

действия в конце каждой итерации цикла) {

инструкция цикла;

инструкция цикла 2;

инструкция цикла N;

}

Итерацией цикла называется один проход этого цикла

Существует частный случай этой записи, который мы сегодня и разберем:

for (счетчик = значение; счетчик < значение; шаг цикла) {

тело цикла;

}

Счетчик цикла — это переменная, в которой хранится количество проходов данного цикла.

Описание синтаксиса

Сначала присваивается первоначальное значение счетчику, после чего ставится точка с запятой.

Затем задается конечное значение счетчика цикла. После того, как значение счетчика достигнет указанного предела, цикл завершится. Снова ставим точку с запятой.

Задаем шаг цикла. Шаг цикла — это значение, на которое будет увеличиваться или уменьшаться счетчик цикла при каждом проходе.

Пример кода

Напишем программу, которая будет считать сумму всех чисел от 1 до 1000.

#include <iostream>

using namespace std;

int main()

{

int i; // счетчик цикла

int sum = 0; // сумма чисел от 1 до 1000.

setlocale(0, "");

for (i = 1; i <= 1000; i++) // задаем начальное значение 1, конечное 1000 и задаем шаг цикла - 1.

{

sum = sum + i;

}

cout << "Сумма чисел от 1 до 1000 = " << sum << endl;

return 0;

}

Если мы скомпилируем этот код и запустим программу, то она покажет нам ответ: 500500. Это и есть сумма всех целых чисел от 1 до 1000. Если считать это вручную, понадобится очень много времени и сил. Цикл выполнил всю рутинную работу за нас.

Заметьте, что конечное значение счетчика я задал нестрогим неравенством ( <= — меньше либо равно), поскольку, если бы я поставил знак меньше, то цикл произвел бы 999 итераций, т.е. на одну меньше, чем требуется. Это довольно важный момент, т.к. здесь новички часто допускают ошибки, особенно при работе с массивами (о них будет рассказано в следующем уроке). Значение шага цикла я задал равное единице. i++ — это тоже самое, что и i = i + 1.

В теле цикла, при каждом проходе программа увеличивает значение переменной sum на i. Еще один очень важный момент — в начале программы я присвоил переменной sum значение нуля. Если бы я этого не сделал, программа вылетела вы в сегфолт. При объявлении переменной без ее инициализации что эта переменная будет хранить «мусор».

Естественно к мусору мы ничего прибавить не можем. Некоторые компиляторы, такие как gcc, инициализирует переменную нулем при ее объявлении.

Объяснение:

Почитай полезно будет,прочитав сразу решишь задачу,она очень простая, подумай чутка)

Хачатурович978

Paint.NET создан как проект старшекурсников по компьютерным наукам весной 2004 года. Рик Брюстер, один из основных разработчиков, в своём блоге сказал, что версия 1.0 была написана «за 4 месяца… и содержала 36 000 строк кода»[7]. Недавний[уточнить] релиз, версия 3.10 — приблизительно 140 000 строк кода. Проект Paint.NET продолжался летом и по осенний семестр 2004 г., в результате чего появились версии 1.1 и 2.0.

Двое выпускников Университета штата Вашингтон, которые работали над проектом в студенческие годы, продолжают его развитие и сейчас[уточнить], являясь сотрудниками Microsoft.

По состоянию на май 2006 года программа была загружена по крайней мере 2 миллиона раз[8], с частотой порядка 180 000 в месяц[9].

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На вход программе подаётся последовательность символов, заканчивающаяся точкой. требуется написать программу, которая определяет, есть ли в этой последовательности цифры, и выводит наибольшее число, которое можно составить из этих цифр. ведущих нулей быть не должно, за исключением одного нуля. если числа нет, выводится сообщение 'no', если число есть - 'да' и в следующей строке искомое число. например, если исходная последовательность была такая: day 10, mice 8: "year" 7 is a mistake 91. то результат должен быть следующий: да 987110
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Вера1072
Panei
daryagulyaeva
s-shulga
esnails17
rimmatrotskaia303
Никита_Тузов
AnastasiyaSkripin1283
Stenenko
semenov-1970
Maksimova-Shorokhov303
fotostock
kirik197308
Лоскутова
sgritsaev
▲