miheev-oleg578
?>

99 гуманитарию 1.√(√у-5*у+8) составьте программу.ответ запишите с функций round, int и frac. 2.написать программу.для х, заданного вычислите "у" по формуле у=х в кубе+2, 5х в квадрате -х+1 при этом: а)в одном операторе присваивания можно использовать не более одной орифметической операции; б)в программе может быть использовано не более пяти операторов присваивания в)операцию возведения в степень использовать запрещено! 3.составить программу, которая вычислит длину гипотенузы. конечный ответ округлить до 4 цифр после запятой.

Информатика

Ответы

Caragyant
1.
var y:real;
begin
write('y = ');
readln(y);
writeln(sqrt(sqrt(y)-5*y+8):5:3);
end.

Пример:
y = 0.09
2.802

2.
var x,y,t1,t2,t3:real;
begin
write('x = ');
readln(x);
t1:=x*x;    // x^2
t2:=x+2.5;  // x+2.5
t3:=t1*t2;  // x^3+2.5*x^2
y:=t3-x;    // x^3+2.5*x^2-x
y:=y+1;     // x^3+2.5*x^2-x+1
writeln('1) y = ',y:5:2);
writeln('2) y = ',x*x*x+2.5*x*x-x+1:5:2);
end.

Пример:
x = 3
1) y = 47.50
2) y = 47.50

3.
var a,b,c:real;
begin
write('a = ');
readln(a);
write('b = ');
readln(b);
c:=sqrt(a*a+b*b);
writeln('c = ',c:6:4);
end.

Пример:
a = 3
b = 4
c = 5.0000
sveremeev816
//Визуально разделил циклы, чтобы было более читаемо 

var ar:array[1..10] of integer;
max,i:integer;
begin;
randomize; //чтобы random() работал как надо
writeln('Array');

for i:=1 to 10 do
begin;
ar[i]:=random(-10,10); //случайное число от -10 до 10
write(ar[i]:4);
end;

for i:=1 to 10 do //"проходим" через весь массив
if (ar[i]<0) and (max<abs(ar[i])) then max:=abs(ar[i]);
{если элемент массива меньше нуля и его модуль больше максимума тогда записать модуль этого числа в максимум}

writeln;
writeln('Max:-',max); //выводим на всякий случай максимум

writeln('Final array:');
for i:=1 to 10 do //снова проходим по всему массиву
begin;
if ar[i]=-max then ar[i]:=0; 
{если элемент равен отрицательному максимуму(мы брали модуль) присвоить ему 0}
write(ar[i]:4);
end;
end.
vasilevich-F
// PascalABC.Net 3.0, сборка 1066
type
  Point=record
  x,y:double;
  end;

procedure GetPoint(c:char; var M:point);
begin
  Write('введите координаты точки ',c,': ');
  Read(M.x,M.y)
end;

function L(A,B:Point):double;
begin
  Result:=sqrt(sqr(B.x-A.x)+sqr(B.y-A.y))
end;

function S(A,B,C:Point):double;
var
  p,la,lb,lc:double;
begin
  la:=L(A,B); lb:=L(B,C); lc:=L(C,A);
  if (la+lb>lc) and (la+lc>lb) and (lb+lc>la) then begin
    p:=0.5*(la+lb+lc);
    Result:=sqrt(p*(p-la)*(p-lb)*(p-lc))
    end
  else
    Result:=0
end;

var
  A,B,C,D:Point;
  S1,S2:double;

begin
  GetPoint('A',A);
  GetPoint('B',B);
  GetPoint('C',C);
  GetPoint('D',D);
  S1:=S(A,B,C);
  if S1=0 then Write('По точкам А,В,С нельзя построить треугольник')
  else begin
    S2:=S(C,D,A);
    if S2=0 then Write('По точкам C,D,A нельзя построить треугольник')
    else Writeln('Площадь четырехугольника равна ',S1+S2)
  end
end.

Тестовое решение:
введите координаты точки A: -5 -7
введите координаты точки B: -2 4
введите координаты точки C: 5 9
введите координаты точки D: 9 -3
Площадь четырехугольника равна 123

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

99 гуманитарию 1.√(√у-5*у+8) составьте программу.ответ запишите с функций round, int и frac. 2.написать программу.для х, заданного вычислите "у" по формуле у=х в кубе+2, 5х в квадрате -х+1 при этом: а)в одном операторе присваивания можно использовать не более одной орифметической операции; б)в программе может быть использовано не более пяти операторов присваивания в)операцию возведения в степень использовать запрещено! 3.составить программу, которая вычислит длину гипотенузы. конечный ответ округлить до 4 цифр после запятой.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Воздвиженская
ivstigres65
ev89036973460
k-serga1
Елена Васильева839
ivnivas2008
ikavto6
romka1210
Константин Андрей
satinvova
scraer198258
Nataliatkachenko1
tkmandarin8376
hristos1212
catmos