yuliyaminullina
?>

Составить программу ввода оценки p (1< =p< =5), полученной учащимся, и выдачи текста: "молодец! ", если p=5; "хорошо! ", если p=4; "лентяй! ", если p< =3.

Информатика

Ответы

MelnikovaIvanovna
Var
  p: integer;

begin
  readln(p);
  if p=5 then print('Молодец!')
  else if p = 4 then print('Хорошо!')
  else if p<=3 then print('Лентяй!')
end.
komplekt7
Точный ответ из "реальной жизни" звучит "это зависит от...". На самом деле, это зависит от дофига чего: от типа сети, используемых протоколов, загруженности каналов, коммутаторов и т. п.

(очень)грубая оценка для 100 мегабитного проводного ethernet примерно так: 100 МБит/с это примерно 10 МБайт/с (соотношение 10, хотя в байте бит по прежнему 8, это из-за всякие типовых накладных расходов, расхождения единиц измерения). 500 МБайт / 10 МБайт/с = 50 секунд.

Если чистая арифметика и пофиг на жизнь, то 500 Мбайт = (500 * 1024 * 1024) байт = (50 * 1024 * 1024 * 8) бит

Все это поделить на 100 000 000 бит/с и получится время в секундах. То есть 41,94304 секунд
Shikhova-Vitalii1290
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
  Writeln('Максимальный четный элемент: ',a.Where(x->x.IsEven).Max);
end.

Пример
n= 15
49 -55 14 3 -29 -18 -23 -54 -82 -68 75 45 86 0 -82
Максимальный четный элемент: 86

begin
  var a:=ArrRandom(ReadInteger('n='),-37,66); a.Println;
  Writeln('Минимальный нечетный элемент: ',a.Where(x->x.IsOdd).Min);
end.

Пример
n= 13
-8 25 -1 40 52 -6 34 -23 44 -30 -14 -6 33
Минимальный нечетный элемент: -23

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу ввода оценки p (1< =p< =5), полученной учащимся, и выдачи текста: "молодец! ", если p=5; "хорошо! ", если p=4; "лентяй! ", если p< =3.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Yevgenii_Gurtovaya1532
titovass9
klykovav672
федороа
ghjcnjtyjn64
vladimir152
Виктория-Марина626
Bologova Golovach1989
blackpoint2020273
Klochkov malakhov1974
boldyrevanastia22
svetsalikowa
Остап-Лаврова1410
catmos
vera-classic75